summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.1.0-r2.ebuild')
-rw-r--r--dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.1.0-r2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.1.0-r2.ebuild b/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.1.0-r2.ebuild
deleted file mode 100644
index 3f22ce59f2f1..000000000000
--- a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.1.0-r2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/mri/extconf.rb)
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements bcrypt_pdkfd (a variant of PBKDF2 with bcrypt-based PRF)"
-HOMEPAGE="https://github.com/net-ssh/bcrypt_pbkdf-ruby"
-
-LICENSE="MIT"
-SLOT="1"
-KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-ssl )"
-
-all_ruby_prepare() {
- # Don't use a ruby-bundled version of libsodium
- sed -i -e '/rbnacl\/libsodium/ s:^:#:' test/bcrypt_pnkdf/engine_test.rb || die
-
- # Avoid unneeded rake-compiler dependency
- sed -e '/extensiontask/ s:^:#:' -e '/ExtensionTask/,/^end/ s:^:#:' \
- -e '/bundler/ s:^:#:' \
- -i Rakefile || die
-
- # Fix minitest deprecation
- sed -e 's/MiniTest::Unit::TestCase/Minitest::Test/' \
- -i test/*/*_test.rb || die
-
- sed -i -e 's/git ls-files/find * -print/' bcrypt_pbkdf.gemspec || die
-}
-
-each_ruby_configure() {
- each_fakegem_configure
- # Some methods may not be inlined on x86 but they are not defined either, bug 629164
-
- sed -i -e 's:-Wl,--no-undefined::' ext/mri/Makefile || die
-}