summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-vte3/ruby-vte3-3.1.1.ebuild')
-rw-r--r--dev-ruby/ruby-vte3/ruby-vte3-3.1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/ruby-vte3/ruby-vte3-3.1.1.ebuild b/dev-ruby/ruby-vte3/ruby-vte3-3.1.1.ebuild
new file mode 100644
index 000000000000..bdcb0a11580a
--- /dev/null
+++ b/dev-ruby/ruby-vte3/ruby-vte3-3.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+inherit virtualx ruby-ng-gnome2
+
+DESCRIPTION="Ruby VTE bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" x11-libs/vte:2.91"
+RDEPEND+=" x11-libs/vte:2.91"
+
+ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
+ruby_add_rdepend ">=dev-ruby/ruby-gtk3-${PV}"
+
+all_ruby_prepare() {
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+
+ # Avoid tests that require a real pty.
+ rm -f test/test-pty.rb || die
+}
+
+each_ruby_configure() {
+ :
+}
+
+each_ruby_compile() {
+ :
+}
+
+each_ruby_test() {
+ VIRTUALX_COMMAND=${RUBY}
+ virtualmake test/run-test.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}