summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/cri/cri-2.15.11-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/cri/cri-2.15.11-r1.ebuild b/dev-ruby/cri/cri-2.15.11-r1.ebuild
index 375a788eac28..edda0c798a2f 100644
--- a/dev-ruby/cri/cri-2.15.11-r1.ebuild
+++ b/dev-ruby/cri/cri-2.15.11-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,9 @@ all_ruby_prepare() {
sed -e '/coveralls/I s:^:#:' -i test/helper.rb || die
sed -i -e '/rubocop/ s:^:#:' \
-e '/RuboCop/,/end/ s:^:#:' Rakefile || die
+
+ sed -e 's/MiniTest::Unit::TestCase/Minitest::Test/' \
+ -i test/helper.rb || die
}
each_ruby_test() {