summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/csindex')
-rw-r--r--dev-tex/csindex/Manifest1
-rw-r--r--dev-tex/csindex/csindex-2.11c-r1.ebuild37
-rw-r--r--dev-tex/csindex/files/csindex-2.11c-decl.patch25
-rw-r--r--dev-tex/csindex/files/csindex-2.11c-flags.patch16
-rw-r--r--dev-tex/csindex/metadata.xml12
5 files changed, 91 insertions, 0 deletions
diff --git a/dev-tex/csindex/Manifest b/dev-tex/csindex/Manifest
new file mode 100644
index 000000000000..871ee9d85a92
--- /dev/null
+++ b/dev-tex/csindex/Manifest
@@ -0,0 +1 @@
+DIST csindex-19980713.tar.gz 31778 SHA256 3ccb0822c40862aab30d923d367d1f053b85ee3d79865cca5c76f1b80e6b57f7 SHA512 ab4d35c84272aa64f9613023412cf8fb8d0b565ffd1fe61b397f82911b6ff7c230c4f54ff44aa0ea5a512229e7ee9410a9257c3fc7ee1d0ba267151ab1704130 WHIRLPOOL bb2f40f52b96aebd0188b1d6a792b0d2cd37073d02acabd932ca16ce097d9f9c8b303345774fb0f9203e62e5bead9c059ee12bf97feb90c64d4594b8e41a0f1d
diff --git a/dev-tex/csindex/csindex-2.11c-r1.ebuild b/dev-tex/csindex/csindex-2.11c-r1.ebuild
new file mode 100644
index 000000000000..b1eb05a562c0
--- /dev/null
+++ b/dev-tex/csindex/csindex-2.11c-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs eutils
+
+MY_P="${PN}-19980713"
+
+DESCRIPTION="Utility for creating Czech/Slovak-sorted LaTeX index-files"
+HOMEPAGE="http://math.feld.cvut.cz/olsak/cstex/"
+SRC_URI="ftp://math.feld.cvut.cz/pub/cstex/base/${MY_P}.tar.gz"
+
+LICENSE="MakeIndex"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-flags.patch" \
+ "${FILESDIR}/${P}-decl.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ dobin csindex || die
+ dodoc README
+}
diff --git a/dev-tex/csindex/files/csindex-2.11c-decl.patch b/dev-tex/csindex/files/csindex-2.11c-decl.patch
new file mode 100644
index 000000000000..c02d456f181f
--- /dev/null
+++ b/dev-tex/csindex/files/csindex-2.11c-decl.patch
@@ -0,0 +1,25 @@
+Index: csindex-19980713/mkind.c
+===================================================================
+--- csindex-19980713.orig/mkind.c
++++ csindex-19980713/mkind.c
+@@ -32,6 +32,8 @@
+ #ifdef CS_INDEX
+ #include <string.h>
+ #endif
++#include <unistd.h>
++
+
+ int letter_ordering = FALSE;
+ int compress_blanks = FALSE;
+Index: csindex-19980713/mkind.h
+===================================================================
+--- csindex-19980713.orig/mkind.h
++++ csindex-19980713/mkind.h
+@@ -720,6 +720,7 @@ extern void scan_idx ARGS((void));
+ extern void scan_sty ARGS((void));
+ extern void sort_idx ARGS((void));
+ extern int strtoint ARGS((char *str));
++char *strlwr(char *a);
+
+ #if __STDC__
+ #include <stdlib.h>
diff --git a/dev-tex/csindex/files/csindex-2.11c-flags.patch b/dev-tex/csindex/files/csindex-2.11c-flags.patch
new file mode 100644
index 000000000000..f13914b2eeed
--- /dev/null
+++ b/dev-tex/csindex/files/csindex-2.11c-flags.patch
@@ -0,0 +1,16 @@
+Index: csindex-19980713/Makefile
+===================================================================
+--- csindex-19980713.orig/Makefile
++++ csindex-19980713/Makefile
+@@ -1,9 +1,9 @@
+ DEFS=-DOS_SYSV
+ OBJS=csindex.o genind.o mkind.o qsort.o scanid.o scanst.o sortid.o
+-CFLAGS= -O2 $(DEFS)
++CFLAGS+= $(DEFS)
+
+ all: csindex
+
+ csindex: $(OBJS)
+- $(CC) -o csindex $(DEFS) $(OBJS) -lm
++ $(CC) $(LDFLAGS) -o csindex $(DEFS) $(OBJS) -lm
+
diff --git a/dev-tex/csindex/metadata.xml b/dev-tex/csindex/metadata.xml
new file mode 100644
index 000000000000..040f708c8404
--- /dev/null
+++ b/dev-tex/csindex/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>malenko@email.cz</email>
+ <name>Jaromir Malenko</name>
+ <description>Jaromir is helping us with Czeck and Slovak support in
+ Gentoo. He is also a maintainer of cstetex. See bug #31657</description>
+</maintainer>
+</pkgmetadata>