summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/kscope')
-rw-r--r--dev-util/kscope/Manifest1
-rw-r--r--dev-util/kscope/files/kscope-1.9.4-actions.patch90
-rw-r--r--dev-util/kscope/files/kscope-1.9.4-underlinking.patch13
-rw-r--r--dev-util/kscope/kscope-1.9.4-r1.ebuild38
-rw-r--r--dev-util/kscope/metadata.xml8
5 files changed, 150 insertions, 0 deletions
diff --git a/dev-util/kscope/Manifest b/dev-util/kscope/Manifest
new file mode 100644
index 000000000000..9fe7a8e8de8d
--- /dev/null
+++ b/dev-util/kscope/Manifest
@@ -0,0 +1 @@
+DIST kscope-1.9.4.tar.gz 127892 SHA256 7bd35960afa29026f8e0c4a827868e93b4d7c6e81796ceb89f086efbc24636df SHA512 744bd8a57031c0253e37521ddc42ee1cc173bfb8490130592a1a6478525c3ea0bcc17d2c2e01adb72cc14adc96298ee69a235c16fc2a42b301de4d30ef287a3b WHIRLPOOL 9a589021253cae7625178cc3e90db9537cc795c967c45e408d10e50d305624c8dfc92208bc64331f4478b46eede5da08b2109ba42f4e990140f2736694c10d2b
diff --git a/dev-util/kscope/files/kscope-1.9.4-actions.patch b/dev-util/kscope/files/kscope-1.9.4-actions.patch
new file mode 100644
index 000000000000..d333efb0ab09
--- /dev/null
+++ b/dev-util/kscope/files/kscope-1.9.4-actions.patch
@@ -0,0 +1,90 @@
+--- trunk/app/actions.cpp 2009/08/26 13:17:03 203
++++ trunk/app/actions.cpp 2009/09/07 19:58:30 204
+@@ -264,69 +264,58 @@
+ QActionGroup* queryGroup = new QActionGroup(this);
+ connect(queryGroup, SIGNAL(triggered(QAction*)), this,
+ SLOT(query(QAction*)));
++ connect(ProjectManager::signalProxy(), SIGNAL(hasProject(bool)),
++ queryGroup, SLOT(setEnabled(bool)));
++ queryGroup->setEnabled(false);
+
+ // Query references.
+- action = new QAction(tr("&References"), this);
++ action = new QAction(tr("&References"), queryGroup);
+ action->setShortcut(tr("Ctrl+0"));
+ action->setStatusTip(tr("Find all symbol references"));
+ action->setData(Core::Query::References);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Query definition.
+- action = new QAction(tr("&Definition"), this);
++ action = new QAction(tr("&Definition"), queryGroup);
+ action->setShortcut(tr("Ctrl+1"));
+ action->setStatusTip(tr("Find symbol definition"));
+ action->setData(Core::Query::Definition);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Query called functions.
+- action = new QAction(tr("&Called Functions"), this);
++ action = new QAction(tr("&Called Functions"), queryGroup);
+ action->setShortcut(tr("Ctrl+2"));
+ action->setStatusTip(tr("Show functions called from function"));
+ action->setData(Core::Query::CalledFunctions);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Query calling functions.
+- action = new QAction(tr("C&alling Functions"), this);
++ action = new QAction(tr("C&alling Functions"), queryGroup);
+ action->setShortcut(tr("Ctrl+3"));
+ action->setStatusTip(tr("Find functions calling function"));
+ action->setData(Core::Query::CallingFunctions);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Query text.
+- action = new QAction(tr("&Text"), this);
++ action = new QAction(tr("&Text"), queryGroup);
+ action->setShortcut(tr("Ctrl+4"));
+ action->setStatusTip(tr("Find text in files"));
+ action->setData(Core::Query::Text);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Find file.
+- action = new QAction(tr("&File"), this);
++ action = new QAction(tr("&File"), queryGroup);
+ action->setShortcut(tr("Ctrl+7"));
+ action->setStatusTip(tr("Find a file"));
+ action->setData(Core::Query::FindFile);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Find including files.
+- action = new QAction(tr("&Including Files"), this);
++ action = new QAction(tr("&Including Files"), queryGroup);
+ action->setShortcut(tr("Ctrl+8"));
+ action->setStatusTip(tr("Find files #including a given file"));
+ action->setData(Core::Query::IncludingFiles);
+ menu->addAction(action);
+- projectGroup->addAction(action);
+- queryGroup->addAction(action);
+
+ // Show local tags.
+ action = new QAction(tr("Local &Tags"), this);
+@@ -348,6 +337,7 @@
+ action->setStatusTip(tr("Create a call tree"));
+ connect(action, SIGNAL(triggered()), mainWnd(), SLOT(promptCallTree()));
+ menu->addAction(action);
++ projectGroup->addAction(action);
+
+ // Settings menu.
+ menu = mainWnd()->menuBar()->addMenu(tr("&Settings"));
diff --git a/dev-util/kscope/files/kscope-1.9.4-underlinking.patch b/dev-util/kscope/files/kscope-1.9.4-underlinking.patch
new file mode 100644
index 000000000000..90b6fc365594
--- /dev/null
+++ b/dev-util/kscope/files/kscope-1.9.4-underlinking.patch
@@ -0,0 +1,13 @@
+diff -ruN kscope-1.9.4.orig/app/app.pro kscope-1.9.4/app/app.pro
+--- kscope-1.9.4.orig/app/app.pro 2009-03-14 12:45:48.000000000 +0100
++++ kscope-1.9.4/app/app.pro 2011-08-07 20:33:04.540575855 +0200
+@@ -58,7 +58,8 @@
+ -L../cscope \
+ -lkscope_cscope \
+ -L../editor \
+- -lkscope_editor
++ -lkscope_editor \
++ -lqscintilla2
+ RESOURCES = app.qrc
+ target.path = $${INSTALL_PATH}/bin
+ INSTALLS += target
diff --git a/dev-util/kscope/kscope-1.9.4-r1.ebuild b/dev-util/kscope/kscope-1.9.4-r1.ebuild
new file mode 100644
index 000000000000..2a68bc3ca96c
--- /dev/null
+++ b/dev-util/kscope/kscope-1.9.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib qt4-r2
+
+DESCRIPTION="Source Editing Environment based on Qt"
+HOMEPAGE="http://kscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kscope/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-libs/qscintilla"
+DEPEND="${RDEPEND}"
+
+DOCS="ChangeLog"
+
+src_prepare() {
+ sed -i -e "s:/usr/local:/usr:" config || die
+ sed -i \
+ -e "s:\$\${QSCI_ROOT_PATH}/include/Qsci:& /usr/include/qt4/Qsci:g" \
+ -e "s:\$\${QSCI_ROOT_PATH}/lib:& -L/usr/lib/qt4:g" \
+ -e "s:/lib:/$(get_libdir):g" \
+ app/app.pro core/core.pro cscope/cscope.pro editor/editor.pro \
+ || die
+
+ # fix build failure with parallel make
+ echo "CONFIG += ordered" >> kscope.pro
+
+ epatch "${FILESDIR}/${P}"-{actions,underlinking}.patch
+}
diff --git a/dev-util/kscope/metadata.xml b/dev-util/kscope/metadata.xml
new file mode 100644
index 000000000000..1857d0bcc627
--- /dev/null
+++ b/dev-util/kscope/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="sourceforge">kscope</remote-id>
+ </upstream>
+</pkgmetadata>