summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/libabigail/libabigail-9999.ebuild')
-rw-r--r--dev-util/libabigail/libabigail-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-util/libabigail/libabigail-9999.ebuild b/dev-util/libabigail/libabigail-9999.ebuild
index 0e0b6d252158..e83ef1cd10f5 100644
--- a/dev-util/libabigail/libabigail-9999.ebuild
+++ b/dev-util/libabigail/libabigail-9999.ebuild
@@ -16,14 +16,14 @@ LIBABIGAIL_DOCS_USEFLAG="+doc"
PYTHON_COMPAT=( python3_{10..12} )
-inherit autotools bash-completion-r1 python-any-r1 out-of-source
+inherit libtool bash-completion-r1 python-any-r1 out-of-source
DESCRIPTION="Suite of tools for checking ABI differences between ELF objects"
HOMEPAGE="https://sourceware.org/libabigail/"
if [[ ${PV} == 9999 ]] ; then
LIBABIGAIL_DOCS_PREBUILT=0
EGIT_REPO_URI="https://sourceware.org/git/libabigail.git"
- inherit git-r3
+ inherit autotools git-r3
else
SRC_URI="https://mirrors.kernel.org/sourceware/libabigail/${P}.tar.xz"
if [[ ${LIBABIGAIL_DOCS_PREBUILT} == 1 ]] ; then
@@ -58,9 +58,11 @@ BDEPEND="
src_prepare() {
default
- # need to run our autotools, due to ltmain.sh including Redhat calls:
- # cannot read spec file '/usr/lib/rpm/redhat/redhat-hardened-ld': No such file or directory
- eautoreconf
+ if [[ ${PV} = 9999 ]] ; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
my_src_configure() {