summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/prismlauncher/prismlauncher-9999.ebuild')
-rw-r--r--games-action/prismlauncher/prismlauncher-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/games-action/prismlauncher/prismlauncher-9999.ebuild b/games-action/prismlauncher/prismlauncher-9999.ebuild
index 1d4b9a04996f..c60586d65332 100644
--- a/games-action/prismlauncher/prismlauncher-9999.ebuild
+++ b/games-action/prismlauncher/prismlauncher-9999.ebuild
@@ -108,9 +108,11 @@ RDEPEND="
src_prepare() {
cmake_src_prepare
+ sed -i -e 's/-Werror//' CMakeLists.txt || die 'Failed to remove -Werror via sed'
+
# Prevent conflicting with the user's flags
- # See https://bugs.gentoo.org/848765 for more info
- sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
+ # See https://bugs.gentoo.org/848765 and https://bugs.gentoo.org/911858 for more info
+ sed -i -e "/CMAKE_CXX_FLAGS_RELEASE/d" CMakeLists.txt || die 'Failed to remove "CMAKE_CXX_FLAGS_RELEASE" from CMakeLists via sed'
}
src_configure(){