summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike/mazesofmonad')
-rw-r--r--games-roguelike/mazesofmonad/Manifest1
-rw-r--r--games-roguelike/mazesofmonad/files/mazesofmonad-1.0.9-time-1.5.patch22
-rw-r--r--games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r2.ebuild62
-rw-r--r--games-roguelike/mazesofmonad/metadata.xml19
4 files changed, 104 insertions, 0 deletions
diff --git a/games-roguelike/mazesofmonad/Manifest b/games-roguelike/mazesofmonad/Manifest
new file mode 100644
index 000000000000..cd2bcd33f2b4
--- /dev/null
+++ b/games-roguelike/mazesofmonad/Manifest
@@ -0,0 +1 @@
+DIST MazesOfMonad-1.0.9.tar.gz 56342 SHA256 02075be1011adc99f69f6438a30b8da4b397aef9dcbaec23134a7524cbc73310 SHA512 a537672907f0bf356574b5c16b9b354cc73133958873e3dfc064f9de2ad7c18bed011f811887edc37c9b40de5529f7954889953946a79da29a255637e81d9612 WHIRLPOOL 1c1c9615bdf2f1597aae495731ed498c416a0f02761c76bbc88697a75a21cf14748fb678a9b0470eea2d0c0e73807319c847d6f63f7648d2b88d8405e24206a1
diff --git a/games-roguelike/mazesofmonad/files/mazesofmonad-1.0.9-time-1.5.patch b/games-roguelike/mazesofmonad/files/mazesofmonad-1.0.9-time-1.5.patch
new file mode 100644
index 000000000000..11ef34ef45f9
--- /dev/null
+++ b/games-roguelike/mazesofmonad/files/mazesofmonad-1.0.9-time-1.5.patch
@@ -0,0 +1,22 @@
+diff --git a/MazesOfMonad.cabal b/MazesOfMonad.cabal
+index db5e5bf..c3b427b 100644
+--- a/MazesOfMonad.cabal
++++ b/MazesOfMonad.cabal
+@@ -34,3 +34,3 @@ Executable mazesofmonad
+ regex-posix, containers, filepath, directory, pretty,
+- array, mtl, old-locale, time
++ array, mtl, old-locale, time, time-locale-compat
+
+diff --git a/src/MoresmauJP/Rpg/Save.hs b/src/MoresmauJP/Rpg/Save.hs
+index 12965b7..238b9b9 100644
+--- a/src/MoresmauJP/Rpg/Save.hs
++++ b/src/MoresmauJP/Rpg/Save.hs
+@@ -10,2 +10,3 @@ import Data.Maybe
+ import Data.Time
++import qualified Data.Time.Locale.Compat as DTLC
+
+@@ -112,3 +113,3 @@ listGames rs name= do
+ if isJust $ bckGame bs
+- then return $ Just (dropExtension x,formatTime defaultTimeLocale (iso8601DateFormat $ Just "%R") $ bckDate bs)
++ then return $ Just (dropExtension x,formatTime DTLC.defaultTimeLocale (DTLC.iso8601DateFormat $ Just "%R") $ bckDate bs)
+ else return Nothing
diff --git a/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r2.ebuild b/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..2b99b2f0deb8
--- /dev/null
+++ b/games-roguelike/mazesofmonad/mazesofmonad-1.0.9-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CABAL_FEATURES="bin"
+inherit eutils haskell-cabal games
+
+MY_PN=MazesOfMonad
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Console-based roguelike Role Playing Game similar to nethack"
+HOMEPAGE="https://github.com/JPMoresmau/MazesOfMonad
+ http://hackage.haskell.org/package/MazesOfMonad"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/gmp-5:0=
+ virtual/libffi:="
+DEPEND="${RDEPEND}
+ >=dev-lang/ghc-7.4.1
+ >=dev-haskell/cabal-1.6
+ dev-haskell/hunit
+ dev-haskell/mtl
+ dev-haskell/random
+ dev-haskell/regex-posix
+ dev-haskell/time-locale-compat
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ games_pkg_setup
+ haskell-cabal_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.9-time-1.5.patch
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --prefix="${GAMES_PREFIX}"
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+}
+
+src_install() {
+ haskell-cabal_src_install
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+ games_pkg_postinst
+}
diff --git a/games-roguelike/mazesofmonad/metadata.xml b/games-roguelike/mazesofmonad/metadata.xml
new file mode 100644
index 000000000000..7ca9c091535d
--- /dev/null
+++ b/games-roguelike/mazesofmonad/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <herd>haskell</herd>
+ <longdescription>
+ MazesOfMonad is a console-based Role Playing Game. You create
+ characters with their strong and weak points, and try to complete
+ mazes that are randomly generated. You can pick up gold and items
+ on the way, meet monsters, and deal with them as you want. You can
+ fight, use magic, bribe, trade, steal... This is only a simple game
+ that I did to see what building a full blown Haskell application
+ is like to develop. Versions 1.0.5 and above are complete
+ and working.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">JPMoresmau/MazesOfMonad</remote-id>
+ </upstream>
+</pkgmetadata>