summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-shell-extension-appindicator')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-50.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/Manifest b/gnome-extra/gnome-shell-extension-appindicator/Manifest
index 9a405e9d271b..23169f1b934f 100644
--- a/gnome-extra/gnome-shell-extension-appindicator/Manifest
+++ b/gnome-extra/gnome-shell-extension-appindicator/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extension-appindicator-46.tar.gz 60986 BLAKE2B 3d058aed56c9ba3c931fe50ca2b5cf48f89b32765afbc5adf6c8004f6c68eee874988801a6358ce574a0d3e7f563c81899632e217b8a00a5e1b4ce62e1f31387 SHA512 0616503a9e5a471bbe64b2f2d9fb853ba1d67e902d9b72b464647f70e8e6392ab9135955c87c99e83d96941cb29505f03cab5ad257ffc5a80e77221d4fcd9730
DIST gnome-shell-extension-appindicator-49.tar.gz 65665 BLAKE2B d1e0d151b42a7dc5631927415c05614fa4062b5061278c6d0ca770cf20166f3b88964e514e00fb2aec80ddf4f6dd8fe83fe136e19618d44b1e77a333be8c5144 SHA512 2fed5b3f7042df836cc3ceb1ce303f41de29f56c58570acb5e7150ab4f019e9441e0a91eb71afd5757b465a81a44638eafd2aa5944ff46a71f20095f488ab945
+DIST gnome-shell-extension-appindicator-50.tar.gz 66766 BLAKE2B f57cb082c791e638ee3a0bfeb3b254420bc5bec7736e8a568c3b0b6e57d1a248d4a7020d8cb62f364677e3c13dac39c9f7973f5d8eeead1ce81170f9d517e16e SHA512 bb8e7ab28e64d677812765ad65d587668f948524be8e1f4db62e067a8438a7a77985ad74169cea6f076a2c07979fcc5fa331dbb1bc5b0b954e84e80111870b87
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-50.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-50.ebuild
new file mode 100644
index 000000000000..b59a46a8006e
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-50.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils meson
+
+DESCRIPTION="Support legacy, AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.34
+"
+BDEPEND="
+ app-misc/jq
+"
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}