summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/graphviz/files')
-rw-r--r--media-gfx/graphviz/files/graphviz-2.42.1-libgv_python.patch15
-rw-r--r--media-gfx/graphviz/files/graphviz-2.42.1-math.patch38
2 files changed, 53 insertions, 0 deletions
diff --git a/media-gfx/graphviz/files/graphviz-2.42.1-libgv_python.patch b/media-gfx/graphviz/files/graphviz-2.42.1-libgv_python.patch
new file mode 100644
index 000000000000..426ebbe14a3d
--- /dev/null
+++ b/media-gfx/graphviz/files/graphviz-2.42.1-libgv_python.patch
@@ -0,0 +1,15 @@
+--- a/tclpkg/gv/Makefile.am
++++ b/tclpkg/gv/Makefile.am
+@@ -430,10 +430,10 @@
+ (cd $(DESTDIR)$(pkgpythondir); rm -f _gv.so; $(LN_S) libgv_python.so _gv.so;)
+ endif
+ if WITH_PYTHON2
+- (cd $(DESTDIR)$(pkgpython2dir); rm -f _gv.so; $(LN_S) libgv_python.so _gv.so;)
++ (cd $(DESTDIR)$(pkgpython2dir); rm -f _gv.so; $(LN_S) libgv_python2.so _gv.so;)
+ endif
+ if WITH_PYTHON3
+- (cd $(DESTDIR)$(pkgpython3dir); rm -f _gv.so; $(LN_S) libgv_python.so _gv.so;)
++ (cd $(DESTDIR)$(pkgpython3dir); rm -f _gv.so; $(LN_S) libgv_python3.so _gv.so;)
+ endif
+ if WITH_R
+ (cd $(DESTDIR)$(pkgRdir); rm -f gv.so; $(LN_S) libgv_R.so gv.so;)
diff --git a/media-gfx/graphviz/files/graphviz-2.42.1-math.patch b/media-gfx/graphviz/files/graphviz-2.42.1-math.patch
new file mode 100644
index 000000000000..59b84817a99b
--- /dev/null
+++ b/media-gfx/graphviz/files/graphviz-2.42.1-math.patch
@@ -0,0 +1,38 @@
+diff --git a/lib/sfio/sfdlen.c b/lib/sfio/sfdlen.c
+index 2b4f8b0a3..3b2c75066 100644
+--- a/lib/sfio/sfdlen.c
++++ b/lib/sfio/sfdlen.c
+@@ -13,6 +13,8 @@
+
+ #include "sfhdr.h"
+
++#include <math.h>
++
+ /* Return the length of a double value if coded in a portable format
+ **
+ ** Written by Kiem-Phong Vo
+diff --git a/lib/sfio/sfgetd.c b/lib/sfio/sfgetd.c
+index 535b2cb9a..607681e60 100644
+--- a/lib/sfio/sfgetd.c
++++ b/lib/sfio/sfgetd.c
+@@ -13,6 +13,8 @@
+
+ #include "sfhdr.h"
+
++#include <math.h>
++
+ /* Read a portably coded double value
+ **
+ ** Written by Kiem-Phong Vo
+diff --git a/lib/sfio/sfputd.c b/lib/sfio/sfputd.c
+index 64ab9eaf3..a2dbd225c 100644
+--- a/lib/sfio/sfputd.c
++++ b/lib/sfio/sfputd.c
+@@ -14,6 +14,7 @@
+ #include "sfhdr.h"
+
+ #include <float.h>
++#include <math.h>
+
+ /* Write out a floating point value in a portable format
+ **