summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/freecad/freecad-0.19.1.ebuild3
-rw-r--r--media-gfx/freecad/freecad-0.19.2.ebuild3
-rw-r--r--media-gfx/freecad/freecad-9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/media-gfx/freecad/freecad-0.19.1.ebuild b/media-gfx/freecad/freecad-0.19.1.ebuild
index 1d7e61445995..0589fef979f4 100644
--- a/media-gfx/freecad/freecad-0.19.1.ebuild
+++ b/media-gfx/freecad/freecad-0.19.1.ebuild
@@ -214,6 +214,9 @@ src_configure() {
-DFREECAD_USE_QT_FILEDIALOG=ON
-DFREECAD_USE_QTWEBMODULE:STRING="Qt WebEngine"
+ # Use the version of shiboken2 that matches the selected python version
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+
-DOCC_INCLUDE_DIR="${CASROOT}"/include/opencascade
-DOCC_LIBRARY_DIR="${CASROOT}"/$(get_libdir)
-DOCCT_CMAKE_FALLBACK=ON # don't use occt-config which isn't included in opencascade for Gentoo
diff --git a/media-gfx/freecad/freecad-0.19.2.ebuild b/media-gfx/freecad/freecad-0.19.2.ebuild
index 393c42ede035..99e81bfeeed4 100644
--- a/media-gfx/freecad/freecad-0.19.2.ebuild
+++ b/media-gfx/freecad/freecad-0.19.2.ebuild
@@ -227,6 +227,9 @@ src_configure() {
-DFREECAD_USE_QT_FILEDIALOG=ON
-DFREECAD_USE_QTWEBMODULE:STRING="Qt WebEngine"
+ # Use the version of shiboken2 that matches the selected python version
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+
# install python modules to site-packages' dir. True only for the main package,
# sub-packages will still be installed inside /usr/lib64/freecad
-DINSTALL_TO_SITEPACKAGES=ON
diff --git a/media-gfx/freecad/freecad-9999.ebuild b/media-gfx/freecad/freecad-9999.ebuild
index 765ee01a7a03..26f5cab4f42b 100644
--- a/media-gfx/freecad/freecad-9999.ebuild
+++ b/media-gfx/freecad/freecad-9999.ebuild
@@ -224,6 +224,9 @@ src_configure() {
-DFREECAD_USE_QT_FILEDIALOG=ON
-DFREECAD_USE_QTWEBMODULE:STRING="Qt WebEngine"
+ # Use the version of shiboken2 that matches the selected python version
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+
# install python modules to site-packages' dir. True only for the main package,
# sub-packages will still be installed inside /usr/lib64/freecad
-DINSTALL_TO_SITEPACKAGES=ON