summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libtxc_dxtn')
-rw-r--r--media-libs/libtxc_dxtn/Manifest1
-rw-r--r--media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r1.ebuild36
-rw-r--r--media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1.ebuild58
-rw-r--r--media-libs/libtxc_dxtn/metadata.xml5
4 files changed, 100 insertions, 0 deletions
diff --git a/media-libs/libtxc_dxtn/Manifest b/media-libs/libtxc_dxtn/Manifest
new file mode 100644
index 000000000000..a2d4513361f9
--- /dev/null
+++ b/media-libs/libtxc_dxtn/Manifest
@@ -0,0 +1 @@
+DIST libtxc_dxtn-1.0.1.tar.bz2 214038 SHA256 45290d12cdca529a3f41e7fc35c4250fc1b6d2fc16b56680f8401f6aa792ae60 SHA512 56714a8c947d9b1f47e3ccb23cff9e4e57bd131907a82968de521d094a000275b3aaeecff28e9184bcc4f3932baa1a8bfbbefbc970fcd034ff953d0617148479 WHIRLPOOL 387c4f2a6d807e18f38d9c4d90037d4abbe1dd328760ecae6dfffd9cd87a4ceb5dd61e24fc25433aa9853e4a189ff478c0d260fe71debb3f3daf42876e4e117d
diff --git a/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r1.ebuild b/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..2b7e624fbb18
--- /dev/null
+++ b/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib
+
+DESCRIPTION="Helper library for S3TC texture (de)compression"
+HOMEPAGE="http://cgit.freedesktop.org/~mareko/libtxc_dxtn/"
+SRC_URI="http://people.freedesktop.org/~cbrill/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="media-libs/mesa"
+DEPEND="${RDEPEND}"
+
+RESTRICT="bindist"
+
+src_install() {
+ autotools-multilib_src_install
+
+ # libtxc_dxtn is installed as a module (plugin)
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ ewarn "Depending on where you live, you might need a valid license for s3tc"
+ ewarn "in order to be legally allowed to use the external library."
+ ewarn "Redistribution in binary form might also be problematic."
+ ewarn
+ ewarn "You have been warned. Have a nice day."
+}
diff --git a/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1.ebuild b/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1.ebuild
new file mode 100644
index 000000000000..bb7a7fd6f7c1
--- /dev/null
+++ b/media-libs/libtxc_dxtn/libtxc_dxtn-1.0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Helper library for S3TC texture (de)compression"
+HOMEPAGE="http://cgit.freedesktop.org/~mareko/libtxc_dxtn/"
+SRC_URI="http://people.freedesktop.org/~cbrill/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="multilib"
+
+RDEPEND="media-libs/mesa"
+DEPEND="${RDEPEND}"
+
+RESTRICT="bindist"
+
+foreachabi() {
+ if use multilib; then
+ local ABI
+ for ABI in $(get_all_abis); do
+ multilib_toolchain_setup ${ABI}
+ AUTOTOOLS_BUILD_DIR=${WORKDIR}/${ABI} "${@}"
+ done
+ else
+ "${@}"
+ fi
+}
+
+src_configure() {
+ foreachabi autotools-utils_src_configure
+}
+
+src_compile() {
+ foreachabi autotools-utils_src_compile
+}
+
+src_install() {
+ foreachabi autotools-utils_src_install
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+src_test() {
+ :;
+}
+
+pkg_postinst() {
+ ewarn "Depending on where you live, you might need a valid license for s3tc"
+ ewarn "in order to be legally allowed to use the external library."
+ ewarn "Redistribution in binary form might also be problematic."
+ ewarn
+ ewarn "You have been warned. Have a nice day."
+}
diff --git a/media-libs/libtxc_dxtn/metadata.xml b/media-libs/libtxc_dxtn/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/media-libs/libtxc_dxtn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>