summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libwebp/Manifest1
-rw-r--r--media-libs/libwebp/libwebp-1.3.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/libwebp/Manifest b/media-libs/libwebp/Manifest
index 56238ea7e0bc..7167e584180a 100644
--- a/media-libs/libwebp/Manifest
+++ b/media-libs/libwebp/Manifest
@@ -1,3 +1,4 @@
DIST libwebp-1.2.4.tar.gz 4141376 BLAKE2B 522ee427f63ec51040b2813ad4bac9df0c86678ea441a28f36f979b01d35b25d11e5297a139e00ddf3e14bade298d3c1ab9ad3157246926cb9a713d3f51bb205 SHA512 01f21e2c3057f5878b33664d0070832d78420de3cb2fe4379b07ae6a27bb569fd1c27a920fe324beccb96ae7bfa8c05fdd9e7b0aeba6de06ab4d8b084bb38803
DIST libwebp-1.3.1-p20230908.tar.gz 3690666 BLAKE2B 895c9d384e0b40403940db093f8022fa81e67ce980711e3958d6614bf6aa9c9bd2cb01c1eba02b72028474f662f2ac996b14f0df5029690881053d55016dd9ab SHA512 4f93ef865dd653254089c9fdc8209a3add9a909002fbb56fc0784856dc50a6349c95ca6a06cb26601cd4233a09122009d61ad24e67258b069748ad9bb4da0c80
DIST libwebp-1.3.1-p20230912.tar.gz 3690965 BLAKE2B f0d913d0b4516989f60345932e9259af1bfc1af85048a54c0aa25c6fdabd5948fcf59173253f9caa6c4b0ab96724b223ab65dabedd20bc9d6722fa4bfa712b38 SHA512 aa53084668cd5c345f4a73bd6c69c2eb411e73c735e5b6a2f76e935ab0f7519e9064bba9405df18c084686e8b95ba2335e2b534253b113c5a03aa63e259f07a8
+DIST libwebp-1.3.2.tar.gz 4162949 BLAKE2B 12b3ff3aa9952dd32ce13656146556d5efb6a66860249a8676721980aee10253a1b0335685a769d995e9954cd305190a8ed1878ba4fefce9dcaf41a3976f9e3d SHA512 2b624d2ecfbff6b4db2719e38f146722638ae262acd96327073a04451dd05fb27ef70c5681187821d251df728a6be7e89209c861c561a13bfb786495a830bc20
diff --git a/media-libs/libwebp/libwebp-1.3.2.ebuild b/media-libs/libwebp/libwebp-1.3.2.ebuild
new file mode 100644
index 000000000000..533658e7e1a7
--- /dev/null
+++ b/media-libs/libwebp/libwebp-1.3.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="A lossy image compression format"
+HOMEPAGE="https://developers.google.com/speed/webp/download"
+SRC_URI="https://storage.googleapis.com/downloads.webmproject.org/releases/webp/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0/7" # subslot = libwebp soname version
+if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+IUSE="cpu_flags_arm_neon cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 gif +jpeg opengl +png static-libs swap-16bit-csp tiff"
+
+# TODO: dev-lang/swig bindings in swig/ subdirectory
+RDEPEND="gif? ( media-libs/giflib:= )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ opengl? (
+ media-libs/freeglut
+ virtual/opengl
+ )
+ png? ( media-libs/libpng:= )
+ tiff? ( media-libs/tiff:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.3-libpng-pkg-config.patch
+)
+
+src_prepare() {
+ default
+ # Needed for pkg-config patch; use elibtoolize instead if that's ever dropped
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local args=(
+ --enable-libwebpmux
+ --enable-libwebpdemux
+ --enable-libwebpdecoder
+ $(use_enable static-libs static)
+ $(use_enable swap-16bit-csp)
+ $(use_enable jpeg)
+ $(use_enable png)
+ $(use_enable opengl gl)
+ $(use_enable tiff)
+
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable cpu_flags_x86_sse4_1 sse4.1)
+ $(use_enable cpu_flags_arm_neon neon)
+
+ # Only used for gif2webp binary wrt bug #486646
+ $(multilib_native_use_enable gif)
+ )
+
+ ECONF_SOURCE="${S}" econf "${args[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+ dodoc AUTHORS ChangeLog doc/*.txt NEWS README.md
+}