summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/asfrecorder/asfrecorder-1.1.ebuild')
-rw-r--r--media-video/asfrecorder/asfrecorder-1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-video/asfrecorder/asfrecorder-1.1.ebuild b/media-video/asfrecorder/asfrecorder-1.1.ebuild
new file mode 100644
index 000000000000..360b89764c7d
--- /dev/null
+++ b/media-video/asfrecorder/asfrecorder-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+MY_PN="${PN/asfr/ASFR}"
+DESCRIPTION="ASFRecorder - Download Windows Media Streaming files"
+HOMEPAGE="http://sourceforge.net/projects/asfrecorder/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+ # There is a Makefile, but it only works for Cygwin, so we
+ # only compile this single program.
+ cd "${S}"/source
+ $(tc-getCC) -o asfrecorder ${CFLAGS} ${LDFLAGS} asfrecorder.c || die "Build failed"
+}
+
+src_install () {
+ # Again, no makefiles, so just take what we want.
+ dobin source/asfrecorder
+ dodoc README.TXT
+}