summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/vnstat/vnstat-1.17-r1.ebuild')
-rw-r--r--net-analyzer/vnstat/vnstat-1.17-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-analyzer/vnstat/vnstat-1.17-r1.ebuild b/net-analyzer/vnstat/vnstat-1.17-r1.ebuild
index fceff0f93ca9..8aa25d8a3276 100644
--- a/net-analyzer/vnstat/vnstat-1.17-r1.ebuild
+++ b/net-analyzer/vnstat/vnstat-1.17-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/teemutoivola.asc
-inherit toolchain-funcs verify-sig
+inherit flag-o-matic toolchain-funcs verify-sig
DESCRIPTION="Console-based network traffic monitor that keeps statistics of network usage"
HOMEPAGE="https://humdi.net/vnstat/"
@@ -43,6 +43,15 @@ src_prepare() {
src/common.h || die
}
+src_configure() {
+ tc-export CC
+
+ # Fails to build with GCC 10
+ append-flags -fcommon
+
+ default
+}
+
src_compile() {
emake ${PN} ${PN}d $(usex gd ${PN}i '')
}