summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnftnl')
-rw-r--r--net-libs/libnftnl/files/libnftnl-1.1.5-fix-nft-flowtable-test.patch40
-rw-r--r--net-libs/libnftnl/libnftnl-1.1.5.ebuild2
2 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libnftnl/files/libnftnl-1.1.5-fix-nft-flowtable-test.patch b/net-libs/libnftnl/files/libnftnl-1.1.5-fix-nft-flowtable-test.patch
new file mode 100644
index 000000000000..312ff16eecbf
--- /dev/null
+++ b/net-libs/libnftnl/files/libnftnl-1.1.5-fix-nft-flowtable-test.patch
@@ -0,0 +1,40 @@
+From b2388765e0c4405442faa13845419f6a35d0134c Mon Sep 17 00:00:00 2001
+From: Phil Sutter <phil@nwl.cc>
+Date: Mon, 2 Dec 2019 18:29:56 +0100
+Subject: tests: flowtable: Don't check NFTNL_FLOWTABLE_SIZE
+
+Marshalling code around that attribute has been dropped by commit
+d1c4b98c733a5 ("flowtable: remove NFTA_FLOWTABLE_SIZE") so it's value is
+lost during the test.
+
+Assuming that NFTNL_FLOWTABLE_SIZE will receive kernel support at a
+later point, leave the test code in place but just comment it out.
+
+Fixes: d1c4b98c733a5 ("flowtable: remove NFTA_FLOWTABLE_SIZE")
+Signed-off-by: Phil Sutter <phil@nwl.cc>
+Acked-by: Pablo Neira Ayuso <pablo@netfilter.org>
+---
+ tests/nft-flowtable-test.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+(limited to 'tests/nft-flowtable-test.c')
+
+diff --git a/tests/nft-flowtable-test.c b/tests/nft-flowtable-test.c
+index 3edb00d..8ab8d4c 100644
+--- a/tests/nft-flowtable-test.c
++++ b/tests/nft-flowtable-test.c
+@@ -33,9 +33,11 @@ static void cmp_nftnl_flowtable(struct nftnl_flowtable *a, struct nftnl_flowtabl
+ if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_USE) !=
+ nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_USE))
+ print_err("Flowtable use mismatches");
++#if 0
+ if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_SIZE) !=
+ nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_SIZE))
+ print_err("Flowtable size mismatches");
++#endif
+ if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_FLAGS) !=
+ nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_FLAGS))
+ print_err("Flowtable flags mismatches");
+--
+cgit v1.2.1
+
diff --git a/net-libs/libnftnl/libnftnl-1.1.5.ebuild b/net-libs/libnftnl/libnftnl-1.1.5.ebuild
index 9d15d542e452..176587558f12 100644
--- a/net-libs/libnftnl/libnftnl-1.1.5.ebuild
+++ b/net-libs/libnftnl/libnftnl-1.1.5.ebuild
@@ -20,6 +20,8 @@ RDEPEND=">=net-libs/libmnl-1.0.3"
BDEPEND="virtual/pkgconfig"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-fix-nft-flowtable-test.patch )
+
pkg_setup() {
if kernel_is ge 3 13; then
CONFIG_CHECK="~NF_TABLES"