summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.17.5.ebuild6
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.18.1.ebuild6
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.19.2.ebuild6
-rw-r--r--net-misc/gallery-dl/gallery-dl-9999.ebuild6
4 files changed, 8 insertions, 16 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-1.17.5.ebuild b/net-misc/gallery-dl/gallery-dl-1.17.5.ebuild
index 705fa73ec888..f202ee3c50b3 100644
--- a/net-misc/gallery-dl/gallery-dl-1.17.5.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-1.17.5.ebuild
@@ -28,10 +28,8 @@ RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
-src_compile() {
- emake data/completion/{,_}gallery-dl man
-
- distutils-r1_src_compile
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
}
pkg_postinst() {
diff --git a/net-misc/gallery-dl/gallery-dl-1.18.1.ebuild b/net-misc/gallery-dl/gallery-dl-1.18.1.ebuild
index 705fa73ec888..f202ee3c50b3 100644
--- a/net-misc/gallery-dl/gallery-dl-1.18.1.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-1.18.1.ebuild
@@ -28,10 +28,8 @@ RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
-src_compile() {
- emake data/completion/{,_}gallery-dl man
-
- distutils-r1_src_compile
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
}
pkg_postinst() {
diff --git a/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild b/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild
index d3b25012fb26..79c29ccc0450 100644
--- a/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild
@@ -28,10 +28,8 @@ RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
-src_compile() {
- emake data/completion/{,_}gallery-dl man
-
- distutils-r1_src_compile
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
}
pkg_postinst() {
diff --git a/net-misc/gallery-dl/gallery-dl-9999.ebuild b/net-misc/gallery-dl/gallery-dl-9999.ebuild
index d3b25012fb26..79c29ccc0450 100644
--- a/net-misc/gallery-dl/gallery-dl-9999.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-9999.ebuild
@@ -28,10 +28,8 @@ RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
-src_compile() {
- emake data/completion/{,_}gallery-dl man
-
- distutils-r1_src_compile
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
}
pkg_postinst() {