summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/socat/socat-1.7.3.4.ebuild')
-rw-r--r--net-misc/socat/socat-1.7.3.4.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/net-misc/socat/socat-1.7.3.4.ebuild b/net-misc/socat/socat-1.7.3.4.ebuild
index ea696ac13e65..3eba54db2ef8 100644
--- a/net-misc/socat/socat-1.7.3.4.ebuild
+++ b/net-misc/socat/socat-1.7.3.4.ebuild
@@ -2,13 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit flag-o-matic toolchain-funcs
+MY_P=${P/_beta/-b}
DESCRIPTION="Multipurpose relay (SOcket CAT)"
HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
-MY_P=${P/_beta/-b}
-S="${WORKDIR}/${MY_P}"
SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
@@ -23,16 +24,17 @@ DEPEND="
readline? ( sys-libs/readline:= )
tcpd? ( sys-apps/tcp-wrappers )
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
RESTRICT="
test
ssl? ( readline? ( bindist ) )
"
-DOCS=(
- BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
-)
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
PATCHES=(
"${FILESDIR}"/${PN}-1.7.3.4-fno-common.patch
)
@@ -49,6 +51,7 @@ pkg_setup() {
src_configure() {
filter-flags '-Wno-error*' #293324
tc-export AR
+
econf \
$(use_enable ssl openssl) \
$(use_enable readline) \