summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild')
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild
new file mode 100644
index 000000000000..73f518523423
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.37.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
+ net-libs/libosmo-dsp:=
+ dev-libs/boost:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"