summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/mammoth')
-rw-r--r--sci-biology/mammoth/Manifest1
-rw-r--r--sci-biology/mammoth/files/1.0-consistent-system-intrinsic.patch21
-rw-r--r--sci-biology/mammoth/mammoth-1.0-r1.ebuild43
-rw-r--r--sci-biology/mammoth/metadata.xml5
4 files changed, 70 insertions, 0 deletions
diff --git a/sci-biology/mammoth/Manifest b/sci-biology/mammoth/Manifest
new file mode 100644
index 000000000000..584405eb5350
--- /dev/null
+++ b/sci-biology/mammoth/Manifest
@@ -0,0 +1 @@
+DIST mammoth-1.0-src.tgz 319617 SHA256 7a21bc47db4a47cc5ebeeb4c46761a79eece0a802104a3d6189f388a03e59de2
diff --git a/sci-biology/mammoth/files/1.0-consistent-system-intrinsic.patch b/sci-biology/mammoth/files/1.0-consistent-system-intrinsic.patch
new file mode 100644
index 000000000000..63bf9f246750
--- /dev/null
+++ b/sci-biology/mammoth/files/1.0-consistent-system-intrinsic.patch
@@ -0,0 +1,21 @@
+http://gcc.gnu.org/onlinedocs/gcc-4.2.2/gfortran/SYSTEM.html#SYSTEM
+
+This intrinsic is provided in both subroutine and function forms;
+however, only one form can be used in any given program unit.
+
+--- src/6apply_rot_tras.f.orig 2007-12-10 00:51:35.000000000 -0800
++++ src/6apply_rot_tras.f 2007-12-10 00:55:07.000000000 -0800
+@@ -47,11 +47,11 @@
+ endif
+
+
+- call system ('echo $PWD > junk1')
++ i = system ('echo $PWD > junk1')
+ open(unit=21,file='junk1')
+ read(21,'(a340)', end=7) path
+ 7 close(21)
+- call system ('rm -f junk1')
++ i = system ('rm -f junk1')
+
+ c write(6,*)'my path is ', path
+ c write(6,*)tras1,tras2,tras3,
diff --git a/sci-biology/mammoth/mammoth-1.0-r1.ebuild b/sci-biology/mammoth/mammoth-1.0-r1.ebuild
new file mode 100644
index 000000000000..750d95dd894b
--- /dev/null
+++ b/sci-biology/mammoth/mammoth-1.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils fortran-2 flag-o-matic toolchain-funcs
+
+MY_P="${P}-src"
+
+DESCRIPTION="MAtching Molecular Models Obtained from THeory"
+HOMEPAGE="http://ub.cbm.uam.es/software.php"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="mammoth"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="fetch"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_nofetch() {
+ einfo "Download the source code for MAMMOTH from"
+ einfo "${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_prepare() {
+ # Broken with gfortran without this patch
+ epatch "${FILESDIR}"/${PV}-consistent-system-intrinsic.patch
+
+ case $(tc-getFC) in
+ g77) append-fflags -ffixed-line-length-none ;;
+ gfortran) append-fflags -ffixed-line-length-none ;;
+ esac
+
+ # It comes with a custom-modified configure for some reason,
+ # which forces you to pass in the Fortran compiler as a parameter.
+ # Let's do the standard stuff instead.
+ eautoreconf
+}
diff --git a/sci-biology/mammoth/metadata.xml b/sci-biology/mammoth/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/mammoth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>