summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ideep/ideep-3.1.1.ebuild')
-rw-r--r--sci-libs/ideep/ideep-3.1.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/ideep/ideep-3.1.1.ebuild b/sci-libs/ideep/ideep-3.1.1.ebuild
new file mode 100644
index 000000000000..8f892eea0ed5
--- /dev/null
+++ b/sci-libs/ideep/ideep-3.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MYP=pytorch-rls-v${PV}
+DESCRIPTION="Intel® Optimization for Chainer"
+HOMEPAGE="https://github.com/intel/ideep"
+SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/${MYP}.tar.gz
+ -> ${PF}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=( "${FILESDIR}"/${P}-20230825.patch )
+
+S="${WORKDIR}"/ideep-${MYP}
+
+src_install() {
+ doheader -r include/*
+}