summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/mtree/mtree-1.0.1.ebuild')
-rw-r--r--sys-apps/mtree/mtree-1.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/mtree/mtree-1.0.1.ebuild b/sys-apps/mtree/mtree-1.0.1.ebuild
new file mode 100644
index 000000000000..59f2affe7a8d
--- /dev/null
+++ b/sys-apps/mtree/mtree-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="Directory hierarchy mapping tool from FreeBSD"
+HOMEPAGE="http://code.google.com/p/mtree-port/"
+SRC_URI="http://mtree-port.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ # don't install unneeded docs
+ sed -i '/doc_DATA=/d' Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # avoid conflict with app-arch/libarchive
+ rm "${ED}usr/share/man/man5/mtree.5"
+}