summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/systemd-240.ebuild6
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/sys-apps/systemd/systemd-240.ebuild b/sys-apps/systemd/systemd-240.ebuild
index 000f34f01187..84248ba4f3a3 100644
--- a/sys-apps/systemd/systemd-240.ebuild
+++ b/sys-apps/systemd/systemd-240.ebuild
@@ -434,6 +434,12 @@ pkg_postinst() {
systemd_reenable systemd-networkd.service systemd-resolved.service
+ if [[ -z ${ROOT} && -d /run/systemd/system ]]; then
+ ebegin "Reexecuting system manager"
+ systemctl daemon-reexec || FAIL=1
+ eend $?
+ fi
+
if [[ ${FAIL} ]]; then
eerror "One of the postinst commands failed. Please check the postinst output"
eerror "for errors. You may need to clean up your system and/or try installing"
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 000f34f01187..84248ba4f3a3 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -434,6 +434,12 @@ pkg_postinst() {
systemd_reenable systemd-networkd.service systemd-resolved.service
+ if [[ -z ${ROOT} && -d /run/systemd/system ]]; then
+ ebegin "Reexecuting system manager"
+ systemctl daemon-reexec || FAIL=1
+ eend $?
+ fi
+
if [[ ${FAIL} ]]; then
eerror "One of the postinst commands failed. Please check the postinst output"
eerror "for errors. You may need to clean up your system and/or try installing"