summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/palo/palo-9999.ebuild')
-rw-r--r--sys-boot/palo/palo-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-9999.ebuild b/sys-boot/palo/palo-9999.ebuild
new file mode 100644
index 000000000000..e1bb604bc95e
--- /dev/null
+++ b/sys-boot/palo/palo-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic git-r3 toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.95-toolchain.patch
+ sed -i lib/common.h -e '/^#define PALOVERSION/{s|".*"|"'${PV}'"|g}' || die
+}
+
+src_compile() {
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) \
+ makepalo makeipl || die
+ emake CC=$(tc-getCC) iplboot || die
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dodoc palo.conf
+ dohtml README.html
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ INSOPTIONS="-m 0744" doins "${FILESDIR}"/99palo
+}