summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-14.2.10-r1.ebuild (renamed from sys-cluster/ceph/ceph-14.2.10.ebuild)3
-rw-r--r--sys-cluster/ceph/ceph-15.2.4-r1.ebuild (renamed from sys-cluster/ceph/ceph-15.2.4.ebuild)3
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch2
3 files changed, 7 insertions, 1 deletions
diff --git a/sys-cluster/ceph/ceph-14.2.10.ebuild b/sys-cluster/ceph/ceph-14.2.10-r1.ebuild
index f335155f0e1e..a074166f6b20 100644
--- a/sys-cluster/ceph/ceph-14.2.10.ebuild
+++ b/sys-cluster/ceph/ceph-14.2.10-r1.ebuild
@@ -173,6 +173,9 @@ RESTRICT="test? ( userpriv )"
# distribution tarball does not include everything needed for tests
RESTRICT+=" test"
+# create a non-debug release
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
# false positives unless all USE flags are on
CMAKE_WARN_UNUSED_CLI=no
diff --git a/sys-cluster/ceph/ceph-15.2.4.ebuild b/sys-cluster/ceph/ceph-15.2.4-r1.ebuild
index dc446889a8fc..78786763b463 100644
--- a/sys-cluster/ceph/ceph-15.2.4.ebuild
+++ b/sys-cluster/ceph/ceph-15.2.4-r1.ebuild
@@ -178,6 +178,9 @@ RESTRICT="test? ( userpriv )"
# distribution tarball does not include everything needed for tests
RESTRICT+=" test"
+# create a non-debug release
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
# false positives unless all USE flags are on
CMAKE_WARN_UNUSED_CLI=no
diff --git a/sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch b/sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch
index 59663028cfa4..aaa6ee080a33 100644
--- a/sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch
+++ b/sys-cluster/ceph/files/ceph-14.2.10-missing-includes.patch
@@ -7,7 +7,7 @@ index c4c24f6a75..b5631e8b84 100644
#define CEPH_COMMON_BIT_STR_H
+#include <cstdint>
-+#include <ostream>
++#include <iosfwd>
#include <functional>
namespace ceph {