summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
index 7523ff7bd6f6..87f9ee1eb39b 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
@@ -43,15 +43,17 @@ pkg_setup() {
src_unpack() {
# we need headers & test utilities
- git-r3_fetch "https://git.llvm.org/git/libcxx.git
- https://github.com/llvm-mirror/libcxx.git"
+ if use test; then
+ git-r3_fetch "https://git.llvm.org/git/libcxx.git
+ https://github.com/llvm-mirror/libcxx.git"
+ fi
git-r3_fetch
if use test; then
git-r3_checkout https://llvm.org/git/libcxx.git \
"${WORKDIR}"/libcxx '' include utils/libcxx
- git-r3_checkout
fi
+ git-r3_checkout
}
multilib_src_configure() {