summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild')
-rw-r--r--www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild b/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild
new file mode 100644
index 000000000000..e5d61228e287
--- /dev/null
+++ b/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit apache-module depend.apache
+
+DESCRIPTION="Store and configure Apache virtual hosts using LDAP"
+HOMEPAGE="http://modvhostldap.alioth.debian.org/"
+SRC_URI="http://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+APACHE2_MOD_CONF="99_${PN}"
+APACHE2_MOD_DEFINE="VHOST_LDAP LDAP"
+
+DOCFILES="AUTHORS ChangeLog README"
+
+# apache[ldap] is needed to run, but not to compile.
+DEPEND=""
+RDEPEND="=www-servers/apache-2*[ldap]"
+
+need_apache2
+
+src_prepare() {
+ sed -i "s/MOD_VHOST_LDAP_VERSION/\"${PV}\"/g" "${PN}.c" || \
+ die "failed to sed version string"
+}
+
+src_install() {
+ apache-module_src_install
+ insinto /etc/openldap/schema
+ doins mod_vhost_ldap.schema
+}
+
+pkg_postinst() {
+ apache-module_pkg_postinst
+ einfo
+ einfo "Your LDAP server needs to include mod_vhost_ldap.schema and should"
+ einfo "also maintain indices on apacheServerName and apacheServerAlias."
+ einfo
+}