summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/mongrel2/mongrel2-1.11.0-r1.ebuild')
-rw-r--r--www-servers/mongrel2/mongrel2-1.11.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-servers/mongrel2/mongrel2-1.11.0-r1.ebuild b/www-servers/mongrel2/mongrel2-1.11.0-r1.ebuild
new file mode 100644
index 000000000000..65f274ee6cd1
--- /dev/null
+++ b/www-servers/mongrel2/mongrel2-1.11.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A language agnostic web server focused on web applications"
+HOMEPAGE="http://mongrel2.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/zeromq
+ >=net-libs/mbedtls-2.1[havege]
+ dev-db/sqlite:3"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp "${FILESDIR}/systemtls.mak" Makefile || die
+ eapply "${FILESDIR}/${P}-polarssl-platform-590512.patch"
+ eapply_user
+}
+
+src_install() {
+ emake install PREFIX=/usr DESTDIR="${D}"
+ dodoc README examples/configs/mongrel2.conf
+}