summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlbert Diserholt <albert@diserholt.com>2022-01-03 19:12:49 +0100
committerAlbert Diserholt <albert@diserholt.com>2022-01-03 19:12:49 +0100
commit5de3a7b4c863e0aa0c665edde3f525973690c882 (patch)
tree598392b010a31e0355e3b30ce84739c8be250d5e
parentAdd missing dependency in dev-games/aseprite-1.2.30 (diff)
downloadDrauthius-5de3a7b4c863e0aa0c665edde3f525973690c882.tar.gz
Drauthius-5de3a7b4c863e0aa0c665edde3f525973690c882.tar.bz2
Drauthius-5de3a7b4c863e0aa0c665edde3f525973690c882.zip
Fix dependency in dev-games/godot-3.2.3
It seems to always link against theora & theroadec, even when disabled. A patch should probably have been created, but always having it as a dependency and enabling the use flag by default was faster and easier. Signed-off-by: Albert Diserholt <albert@diserholt.com>
-rw-r--r--dev-games/godot/Manifest2
-rw-r--r--dev-games/godot/godot-3.2.3.ebuild20
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
index 98f0e83..3587996 100644
--- a/dev-games/godot/Manifest
+++ b/dev-games/godot/Manifest
@@ -1,4 +1,4 @@
DIST 3.1.1-stable.zip 25427059 BLAKE2B 85c4df448f5af7f96a3f5a3ba8e23e7764f83e1a43b21807ccf3ba66356aa3ec1dc56242dcf7d0c7d1d9efcba56b7eab8cfc32e314d1f35978bd34d2c300f65e SHA512 509b144be7416174a487548b5708367f7ce743b0268a710d0dc9a9fb095eb368a218bf5cd591f38f90bb9a96fa24acab442c503f4ea91b485274503e381569cd
DIST godot-3.2.3.zip 27949594 BLAKE2B 8ade9ebb742327b86ae7d645cf46c3bbb5e03ef07230c42d4113a599e978e03a64e189d08af578e26a569872ed569f0e95fdde8e1f482d02191855fe4e7e29c8 SHA512 2727a6adbca5065ce3d15dbee0aed213b3ac0a4aaa24fe3d34345afdf3e77eec45296d4141999cf51a04fae1d2785781351e77ac23fa7585e618d0f36aae910f
EBUILD godot-3.1.1.ebuild 3794 BLAKE2B 110ee31e86a3a4202cffac3be24dc3037430fd2bc9e4b1c9a6d67c730f5d5250c4df9f539dabb38465a2196877280696cebaf638fdb1031050ab97bf45be9f12 SHA512 af13c9c329ac5b7d33272c0bccfe0e02663d98dd09d4e3342a58c7a083d9b7df0ab5c38fd51ac5bfa5cdbe51f14865f59a8cab20010acec98b5a7ad9825d60b9
-EBUILD godot-3.2.3.ebuild 3730 BLAKE2B 378949918f199d27642d9c624629dae68cf78d16fa20da97ce4f28bd6e56dfe9f6c05467231c9badffdfbffb2ba56d12760c6291bfffea8f42906f48bc24a66f SHA512 6a2d3ae793b0ad0ed776c6c1b44a4af647d925a38b1069944aa5959bfa34e79217bb20699ea57011f6afece446309562dc6e739a1c8f67d98228db91517edeb5
+EBUILD godot-3.2.3.ebuild 3653 BLAKE2B e77bc594215f973ed463a84f520ddcfacb6a1b87524b0c34ad44e5f5eed915e6ce8b3b66b397c3756c4a459b924a9eebdc8df8e8eb77da2b3fd9345f55a530f3 SHA512 bf9b6d6c1a483b275188300286ea18ae13d361dff626b04388eb7222bd46c06d1a22ad8597d95504ee65886fe9466fb13b6bb0130449cb083fc2ac51218925ab
diff --git a/dev-games/godot/godot-3.2.3.ebuild b/dev-games/godot/godot-3.2.3.ebuild
index 8648b1d..31f3cb6 100644
--- a/dev-games/godot/godot-3.2.3.ebuild
+++ b/dev-games/godot/godot-3.2.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6..8} )
+PYTHON_COMPAT=( python2_7 python3_{6..10} )
inherit eutils python-any-r1 scons-utils flag-o-matic llvm desktop
@@ -30,7 +30,7 @@ IUSE="
+mbedtls
+opus
pulseaudio
- theora
+ +theora
+udev
+vorbis
+webp
@@ -50,7 +50,7 @@ DEPEND="
>=media-libs/libpng-1.6.16:0=
>=media-libs/libsndfile-1.0.25-r1
media-libs/libvpx
- theora? ( media-libs/libtheora )
+ media-libs/libtheora
vorbis? ( >=media-libs/libvorbis-1.3.4 )
webp? ( media-libs/libwebp )
opus? ( media-libs/opus )
@@ -99,17 +99,17 @@ src_configure() {
MYSCONS=(
CC="$(tc-getCC)"
CXX="$(tc-getCXX)"
- builtin_enet=$(usex enet)
+ builtin_enet=no
builtin_freetype=no
builtin_libogg=no
builtin_libpng=no
- builtin_libtheora=$(usex theora)
- builtin_libvorbis=$(usex vorbis)
+ builtin_libtheora=no
+ builtin_libvorbis=no
builtin_libvpx=no
- builtin_libwebp=$(usex webp)
- builtin_mbedtls=$(usex mbedtls)
+ builtin_libwebp=no
+ builtin_mbedtls=no
builtin_miniupnpc=no
- builtin_opus=$(usex opus)
+ builtin_opus=no
builtin_pcre2=no
builtin_zlib=no
builtin_zstd=no