summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlbert Diserholt <albert@diserholt.com>2022-02-15 18:43:48 +0100
committerAlbert Diserholt <albert@diserholt.com>2022-02-15 18:43:48 +0100
commit6652cee06be8b67c4f311f0a5d1f32e27267555f (patch)
tree4bf5b87bd58b0ffa0f3d2d31ab32b9bae5f71ac8
parentBump dev-games/godot-3.2.3 (diff)
downloadDrauthius-6652cee06be8b67c4f311f0a5d1f32e27267555f.tar.gz
Drauthius-6652cee06be8b67c4f311f0a5d1f32e27267555f.tar.bz2
Drauthius-6652cee06be8b67c4f311f0a5d1f32e27267555f.zip
dev-games/aseprite-1.2.33
Readded aseprite-skia, since the prebuilt binaries require clang. Signed-off-by: Albert Diserholt <albert@diserholt.com>
-rw-r--r--dev-games/aseprite-skia/Manifest1
-rw-r--r--dev-games/aseprite-skia/aseprite-skia-9999-r96.ebuild89
-rw-r--r--dev-games/aseprite/Manifest9
-rw-r--r--dev-games/aseprite/aseprite-1.2.33.ebuild (renamed from dev-games/aseprite/aseprite-1.2.29.ebuild)42
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.33-system_harfbuzz.patch23
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.33-system_libarchive.patch (renamed from dev-games/aseprite/files/aseprite-1.2.29-system_libarchive.patch)39
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.33-system_libwebp.patch (renamed from dev-games/aseprite/files/aseprite-1.2.29-system_libwebp.patch)29
7 files changed, 173 insertions, 59 deletions
diff --git a/dev-games/aseprite-skia/Manifest b/dev-games/aseprite-skia/Manifest
new file mode 100644
index 0000000..eb5c543
--- /dev/null
+++ b/dev-games/aseprite-skia/Manifest
@@ -0,0 +1 @@
+EBUILD aseprite-skia-9999-r96.ebuild 2147 BLAKE2B 933fbcf7185e0f8cc4da4ec727c11e901dbc999806c0ff6b36b10f1eaffb15b23e8b13ef94d27c8cad95f17c50fd8387ee27b8ff2fb5c5a435176a32fb0fd188 SHA512 0dabaa53975d6b857837a1072e7a057088d6b327fc789b2421f6b2b305d13740193ae9dff708239577b708600789c5d73fd2bd68c00edc2b3301e05ee0e2ef06
diff --git a/dev-games/aseprite-skia/aseprite-skia-9999-r96.ebuild b/dev-games/aseprite-skia/aseprite-skia-9999-r96.ebuild
new file mode 100644
index 0000000..a55cc11
--- /dev/null
+++ b/dev-games/aseprite-skia/aseprite-skia-9999-r96.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9,10} )
+
+inherit python-any-r1 git-r3 ninja-utils
+
+DESCRIPTION="Skia library for Aseprite"
+HOMEPAGE="https://skia.org"
+
+EGIT_REPO_URI="https://github.com/aseprite/skia"
+EGIT_BRANCH="aseprite-m${PR/r/}"
+
+DEPOT_TOOLS_URI="https://chromium.googlesource.com/chromium/tools/depot_tools.git"
+DEPOT_TOOLS_COMMIT="main"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/expat
+ media-libs/harfbuzz
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/libwebp
+ media-libs/freetype:2
+ sys-libs/zlib"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/ninja"
+
+src_unpack() {
+ git-r3_src_unpack
+
+ sed -ri '/third_party\/externals\/(expat|icu|libjpeg|libpng|libwebp|zlib|harfbuzz|freetype)/d' "${S}/DEPS"
+
+ cd "${S}"
+ ./tools/git-sync-deps || die "Failed to sync dependencies"
+
+ EGIT_BRANCH="$DEPOT_TOOLS_COMMIT"
+ git-r3_fetch "$DEPOT_TOOLS_URI"
+ git-r3_checkout "$DEPOT_TOOLS_URI" depot_tools
+}
+
+src_configure() {
+ local myskiaargs=(
+ is_debug=$(usex debug true false)
+ is_official_build=true
+ skia_use_system_expat=true
+ skia_use_system_icu=true
+ skia_use_system_libjpeg_turbo=true
+ skia_use_system_libpng=true
+ skia_use_system_libwebp=true
+ skia_use_system_zlib=true
+ skia_use_sfntly=false
+ skia_use_freetype=true
+ skia_use_harfbuzz=true
+ skia_pdf_subset_harfbuzz=true
+ skia_use_system_freetype2=true
+ skia_use_system_harfbuzz=true
+ )
+
+ cd "${S}"
+ export PATH="$PATH:${S}/depot_tools"
+ gn gen out/$(usex debug Debug Release) --args="${myskiaargs[*]}" || die "Failed to configure skia"
+}
+
+src_compile() {
+ eninja -C "out/$(usex debug Debug Release)" skia modules || die "Failed to compile skia"
+}
+
+src_install() {
+ insinto /var/lib/aseprite-skia/
+ doins -r include
+ doins -r modules
+ insinto /var/lib/aseprite-skia/src
+ doins -r src/gpu
+ doins -r src/core
+ insinto /var/lib/aseprite-skia/third_party
+ doins -r third_party/skcms
+
+ insinto /var/lib/aseprite-skia/out/$(usex debug Debug Release)
+ dodir /var/lib/aseprite-skia/out/$(usex debug Debug Release)
+ doins out/$(usex debug Debug Release)/lib*.a
+}
diff --git a/dev-games/aseprite/Manifest b/dev-games/aseprite/Manifest
index 16d0981..5afde3a 100644
--- a/dev-games/aseprite/Manifest
+++ b/dev-games/aseprite/Manifest
@@ -1,16 +1,17 @@
AUX aseprite-1.2.21-system_libarchive.patch 3563 BLAKE2B 478a69322ec4cf6b7588b8f1dbd85b1eae0a327c87b400b1061197ff09274843703a480efd8a34d8ca77cd22402b8ae2ab2eaa52741e3a72ab73fd3de6bed84f SHA512 9f378d07b44cc5234022ba1b96608a648dbbcca2e07946025642cb9c7daf507072b203b4f97815dab2913977527d3c5b0e8883c2ad2da51cb2551adf6f7840ab
AUX aseprite-1.2.21-system_libwebp.patch 1595 BLAKE2B 5bd386fae6723de0d6068b25d8ba75eedf1ebc4abd94d91325dbc856752eb67c7d851a3a02976b6d048cec4c0d57b5d16007b83fdc32285355b7e94fc0930010 SHA512 14d3ab4c345046cf91e6237825456ef94703f334e1fd9fc6d09a4606c89ea04518e12fdc20956638a60fc42302fca5f47beb73fa3318a3ba4e78f3cac35527cb
-AUX aseprite-1.2.29-system_libarchive.patch 3897 BLAKE2B 40afbda3676a2db0ab755b0f748876ec72e980dd758fbe40b15286ff877530d6d44fda503c6fd54f076ac67b6042e5d37a6ae48f40f812ff0251d2a5e6b2b7ee SHA512 f4607555cec237f9889995ff679ac65f94fc230f0d8e1d71ab181b2e25664cb03a218794dcff2b8e7b591658e5160771e1ca7752ca96a0d9a7f607cb00d79496
-AUX aseprite-1.2.29-system_libwebp.patch 1595 BLAKE2B 5bd386fae6723de0d6068b25d8ba75eedf1ebc4abd94d91325dbc856752eb67c7d851a3a02976b6d048cec4c0d57b5d16007b83fdc32285355b7e94fc0930010 SHA512 14d3ab4c345046cf91e6237825456ef94703f334e1fd9fc6d09a4606c89ea04518e12fdc20956638a60fc42302fca5f47beb73fa3318a3ba4e78f3cac35527cb
AUX aseprite-1.2.30-system_libarchive.patch 3897 BLAKE2B 40afbda3676a2db0ab755b0f748876ec72e980dd758fbe40b15286ff877530d6d44fda503c6fd54f076ac67b6042e5d37a6ae48f40f812ff0251d2a5e6b2b7ee SHA512 f4607555cec237f9889995ff679ac65f94fc230f0d8e1d71ab181b2e25664cb03a218794dcff2b8e7b591658e5160771e1ca7752ca96a0d9a7f607cb00d79496
AUX aseprite-1.2.30-system_libwebp.patch 1595 BLAKE2B 5bd386fae6723de0d6068b25d8ba75eedf1ebc4abd94d91325dbc856752eb67c7d851a3a02976b6d048cec4c0d57b5d16007b83fdc32285355b7e94fc0930010 SHA512 14d3ab4c345046cf91e6237825456ef94703f334e1fd9fc6d09a4606c89ea04518e12fdc20956638a60fc42302fca5f47beb73fa3318a3ba4e78f3cac35527cb
+AUX aseprite-1.2.33-system_harfbuzz.patch 580 BLAKE2B 76874db3b8d1b164dfe46926ebd30dd7f782081104a000ff2c74733f4283aa20710072ddee0cae3022af4d9cf8d5ebd90c5db93dae8f46c05d5b08c2b1efcb3a SHA512 fa36b354e5d42beb7c846a89edbda2d2b6071047eddc1c522a1115fa58b9ccf83a680ff0318cc022feebdda3c98818677c748e10d18c81c0b728b819aca52fc1
+AUX aseprite-1.2.33-system_libarchive.patch 4375 BLAKE2B 15d0956e267d3ab756fd5c1c1799718dd484c501b501a9683b3f3709aded515ece3f0fd2eb87afc3a70e53015cf77d8b9a36505f83d0d8823aca64b3b35e2207 SHA512 ff07fa565fff198e59a4e2667c731d1b7f60886d6ebd34b3d3d513acf51f59f666b6b2743c2e27cf67bc0986936eb11524f2d42b7f629cbfd3930dd6d8218a55
+AUX aseprite-1.2.33-system_libwebp.patch 1871 BLAKE2B 399933e038f6eefa71e95c3256b3ba9f9ac93cc230cf9e6c04f76af5ed77e085f929b1edc5d8a3ce8d69b4f84a384877c9e0745721b9c074c7f56e385b093f44 SHA512 7fb7b7e3a9a5d97e7dcb1668b3aecba33b1903e36ddeaea2d6d5e1c0a39bafc7164345c162133cf198edbbaee5aff81ee19836b660e1fd6af175425d90201f2e
DIST Aseprite-v1.1.13-Source.zip 12809688 BLAKE2B e9d6d58cfeb4b07d63945025a31e5a52c2f65e59f01a65bc3ac2f8feef725b2caeef94f542c70132834280c3227a3a1cf7756a708f6970c12d4fd7aca4e646c3 SHA512 b6dd948223885bc9511a8a0f8427540011dc2a6a4ec3448d3461a5661c7de574487e2306024f9522240490b1784a4231818f2790466d106f8b21259c188ca258
DIST Aseprite-v1.2.21-Source.zip 24477477 BLAKE2B b497cf5b6ba677eb742e44d2ee5d28c60ba57956ca04989e27ac8623832e08161c1cf0b64a9440c4fecf103e083556404d918a09ca61d7c496fdac7fb927b196 SHA512 17b2570f0114213b86e18f65a943867d72a497245b8f45bf22a23ad6ed32bb016c69391341cc0449c4fbc9d31e6f5d564c48a204df1c9f13488ffb4658393fee
-DIST Aseprite-v1.2.29-Source.zip 24627286 BLAKE2B 3e5739f3d2e9ab53a8854c4042a668bbec40940914447921b2b626a1d6c249f1731d082060c79ceeea45ca09ff195847f6206f9925d68206b862fc1204fe601d SHA512 af53890faebadf117e504bf9d2e8c69db8bb6713a6749b72026ff0c3ac310a0c6ef38aa1255b31f88d28942f5123eda5060850bbf5a4bd64fe07796a469febea
DIST Aseprite-v1.2.30-Source.zip 30057883 BLAKE2B fc3a0923c963ae4adf0afc4f2bc9949a5f86123250eb0600ada35e711da35363b7719cbfe0296f1b6faf90e948b58318a56918f926eb3361baf576a81c16280b SHA512 c8534cc093a22078b44c3ae265625292e228e44bca894fbeb137759259862cc8956027a04d6982fdf1b6af2d8cd349842e1fc128827064e000de03e851e6620f
+DIST Aseprite-v1.2.33-Source.zip 56234668 BLAKE2B 4afeaa210a31b26e76fb69c0b13b3c79598336241573c7db17248b37b28776eb95173da6181593f876591c851f4d480e8a83b2360c58b4f10524c05659fbefe0 SHA512 a965b6728283808a8fb8498ff557570014a0247fcb07585f0278088ddb65a79b2727bbfe57ba2edd1f275982c727c733a23013250ce82b1d2a242467b3105337
DIST aseprite-skia-m81-b607b32047-amd64.zip 35390542 BLAKE2B f5f5bc6d237c92a302dd593cb91f02904426d342a5c1484589e9ac3444e226637791c5ae951a7406adf4a75a192009aa19beee0f36c4563e10cd32b6b4c6768e SHA512 6c417f289cc1874aefc4dc08ce2edf055c50106c9351476eafe2d554296e9075046eb726465c58097b0a894e2a709f9830208c44eb6c3c7f6ad53cc7d24e70ce
DIST aseprite-skia-m81-b607b32047-x86.zip 33398654 BLAKE2B b312f09d54e81b1b77c8100443ae1464bbe22edb9ce21fdb17a1b0f56dff728665070ad5b895f70420c0671fac973267271eb864b240fc8a070ca9f2e676b363 SHA512 37a093fb9ab9f6c766f406fa62a610921108b118d2a324cf1e0d6f3b635992034f222ba3eb9a023dc968312e53ede29b6fa18628cfd484eddd52bcfe8383823c
EBUILD aseprite-1.1.13.ebuild 3008 BLAKE2B 7419fdaaa1d9506d841ec9c0af3fa04b930afa98373accff9c9d6ee150d9e2ff3c64e670a800c1e40a118f608b2a6f362a779637c397f77a90802a97eef9557d SHA512 58cb3df2e8b33502021b90adde0459004507c9809ee4e0a06f5ddcbefef3c9758cd7374e7f529309a1c876a98e8983305e18f7f9344350221470a7bcebe9ce49
EBUILD aseprite-1.2.21.ebuild 2189 BLAKE2B c01a0b8b93e6840a60066bfbab19ce275bfd67c0ed5957876d33b3d9afe491b2fb7192bb5b8a57deac7b5df5f933027128d877949e0c9f01c23f17292ae78f67 SHA512 ae8f1833c4041c6aa6bb7b34e15788095d0ec1bb63f8e7aed5cce8219cee1966bd48d794d4cf497b9f6d6877a132676d2d57c3bf31152d5b28b7081dfd20be72
-EBUILD aseprite-1.2.29.ebuild 2673 BLAKE2B 7442d8d8ea89284efeac197ce89c18cf1b2f29daf4cbf21491e458d91d29ae82fcae215780c032f740469f18f036f1dfdf789986e5a2b495a67c5e9d887b90d4 SHA512 89c71e0560227a79957c47996fdbfb8308baa67230c7b365e9faaf7fa65dffe3963c5bc7ab48fec7e20c61c92920740c60b8da41d157adaa6dc49ac64b891c41
EBUILD aseprite-1.2.30.ebuild 2769 BLAKE2B e930dc6f025e428a194d3543fabedc963177cb625dd8354a38f70f5b6d8b8d4c3212a1e3b31771415fa2a3d26953e55db51770fd6f1291aa18b04162dfdb17e5 SHA512 9ee2454b560b5479bc4a55477d50bea3dd6c86175e5a6b816cc95527709b44a4a0e1afdd27d95c5a130e05816afa44b3005445669c7cd9bf1dc7aee391a03c4b
+EBUILD aseprite-1.2.33.ebuild 2529 BLAKE2B 6894a72da565dce8243921de92546db8d448e440f2a9814624a6bdbbaff0cebc32e2c9b455f41fe84c4d003c2dc65e4d73d9e1da100d09424693ba9d1aa2d327 SHA512 e6b88031a9ccf1cbb5dcb0e54bae86a7483c18245bede5798939832bdca6fab22be604691432e44abdfaa484d782b3c05c10d75686ba9e15f46fd37e00c71716
diff --git a/dev-games/aseprite/aseprite-1.2.29.ebuild b/dev-games/aseprite/aseprite-1.2.33.ebuild
index 45f0adb..96d4a58 100644
--- a/dev-games/aseprite/aseprite-1.2.29.ebuild
+++ b/dev-games/aseprite/aseprite-1.2.33.ebuild
@@ -11,25 +11,17 @@ LICENSE="Proprietary"
SLOT="0"
PATCHES=(
+ "${FILESDIR}/${P}-system_harfbuzz.patch"
"${FILESDIR}/${P}-system_libarchive.patch"
"${FILESDIR}/${P}-system_libwebp.patch"
)
-SKIA_VERSION="m81-b607b32047"
-SKIA_BASE_URL="https://github.com/${PN}/skia/releases/download"
-SKIA_URI="
- amd64? (
- ${SKIA_BASE_URL}/${SKIA_VERSION}/Skia-Linux-Release-x64.zip -> ${PN}-skia-${SKIA_VERSION}-amd64.zip
- )
- x86? (
- ${SKIA_BASE_URL}/${SKIA_VERSION}/Skia-Linux-Release-x86.zip -> ${PN}-skia-${SKIA_VERSION}-x86.zip
- )"
-
ASEPRITE_FILE="${PN^}-v${PV//_/-}-Source.zip"
ASEPRITE_URI="https://github.com/${PN}/${PN}/releases/download/v${PV//_/-}/${ASEPRITE_FILE}"
-SRC_URI="${ASEPRITE_URI} ${SKIA_URI}"
+SRC_URI="${ASEPRITE_URI}"
KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}"
IUSE="
debug
@@ -43,6 +35,7 @@ RDEPEND="
app-text/cmark
dev-libs/expat
dev-libs/tinyxml
+ =dev-games/aseprite-skia-9999-r96
media-libs/freetype:2
>=media-libs/giflib-5.0
media-libs/fontconfig
@@ -52,23 +45,19 @@ RDEPEND="
sys-apps/util-linux
sys-libs/zlib
virtual/jpeg:=
+ virtual/opengl
x11-libs/libX11
+ x11-libs/libXcursor
x11-libs/pixman
kde? (
kde-apps/thumbnailers
)"
-DOCS=( EULA.txt
+DOCS=(
+ EULA.txt
docs/ase-file-specs.md
docs/LICENSES.md
- README.md )
-
-src_unpack() {
- mkdir -p "${P}/skia"
- cd "${P}"
- unpack "${ASEPRITE_FILE}"
- ( cd skia && unpack "${PN}-skia-${SKIA_VERSION}-${ARCH}.zip" )
-}
+ README.md)
src_prepare() {
cmake-utils_src_prepare
@@ -82,6 +71,7 @@ src_configure() {
local mycmakeargs=(
-DENABLE_UPDATER=OFF
+ -DENABLE_CCACHE="$(has ccache "${FEATURES}" && echo 'ON' || echo 'OFF')"
-DFULLSCREEN_PLATFORM=ON
-DUSE_SHARED_CMARK=ON
-DUSE_SHARED_CURL=ON
@@ -95,11 +85,15 @@ src_configure() {
-DUSE_SHARED_FREETYPE=ON
-DUSE_SHARED_HARFBUZZ=ON
-DUSE_SHARED_WEBP=ON
- -DWITH_DESKTOP_INTEGRATION=ON
- -DWITH_QT_THUMBNAILER="$(usex kde)"
- -DWITH_WEBP_SUPPORT="$(usex webp)"
+ -DENABLE_DESKTOP_INTEGRATION=ON
+ -DENABLE_QT_THUMBNAILER="$(usex kde)"
+ -DENABLE_WEBP="$(usex webp)"
-DENABLE_MEMLEAK="$(usex memleak)"
- -DSKIA_DIR="${S}/skia"
+ -DLAF_BACKEND=skia
+ -DLAF_WITH_EXAMPLES=OFF
+ -DLAF_WITH_TESTS=OFF
+ -DSKIA_DIR="/var/lib/aseprite-skia"
+ -DSKIA_LIBRARY_DIR="/var/lib/aseprite-skia/out/Release"
)
cmake-utils_src_configure
diff --git a/dev-games/aseprite/files/aseprite-1.2.33-system_harfbuzz.patch b/dev-games/aseprite/files/aseprite-1.2.33-system_harfbuzz.patch
new file mode 100644
index 0000000..f7c8543
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.2.33-system_harfbuzz.patch
@@ -0,0 +1,23 @@
+diff -uNr a/laf/CMakeLists.txt b/laf/CMakeLists.txt
+--- a/laf/CMakeLists.txt 2021-12-01 22:06:08.000000000 +0100
++++ b/laf/CMakeLists.txt 2022-02-15 18:05:31.640137967 +0100
+@@ -44,13 +44,12 @@
+ # Find libraries
+ if(LAF_BACKEND STREQUAL "skia")
+ include(FindSkia)
+-else()
+- if(NOT FREETYPE_LIBRARIES)
+- find_package(Freetype)
+- endif()
+- if(NOT HARFBUZZ_LIBRARIES)
+- find_package(HarfBuzz)
+- endif()
++endif()
++if(NOT FREETYPE_LIBRARIES)
++ find_package(Freetype)
++endif()
++if(NOT HARFBUZZ_LIBRARIES)
++ find_package(HarfBuzz)
+ endif()
+
+ add_subdirectory(third_party)
diff --git a/dev-games/aseprite/files/aseprite-1.2.29-system_libarchive.patch b/dev-games/aseprite/files/aseprite-1.2.33-system_libarchive.patch
index 2434840..8b23f45 100644
--- a/dev-games/aseprite/files/aseprite-1.2.29-system_libarchive.patch
+++ b/dev-games/aseprite/files/aseprite-1.2.33-system_libarchive.patch
@@ -1,8 +1,7 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dae638be8..dd5d17794 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -60,6 +60,7 @@ option(USE_SHARED_CURL "Use your installed copy of curl" off)
+diff -uNr a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2022-01-12 15:10:33.000000000 +0100
++++ b/CMakeLists.txt 2022-01-18 15:06:41.357885045 +0100
+@@ -57,6 +57,7 @@
option(USE_SHARED_GIFLIB "Use your installed copy of giflib" off)
option(USE_SHARED_JPEGLIB "Use your installed copy of jpeglib" off)
option(USE_SHARED_ZLIB "Use your installed copy of zlib" off)
@@ -10,7 +9,7 @@ index dae638be8..dd5d17794 100644
option(USE_SHARED_LIBPNG "Use your installed copy of libpng" off)
option(USE_SHARED_TINYXML "Use your installed copy of tinyxml" off)
option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
-@@ -202,6 +202,15 @@ else()
+@@ -216,6 +217,15 @@
endif()
include_directories(${ZLIB_INCLUDE_DIRS})
@@ -26,12 +25,11 @@ index dae638be8..dd5d17794 100644
# libpng
if(USE_SHARED_LIBPNG)
find_package(PNG REQUIRED)
-diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
-index a9e80d73c..619acac92 100644
---- a/src/app/CMakeLists.txt
-+++ b/src/app/CMakeLists.txt
-@@ -91,9 +91,6 @@ if(WITH_WEBP_SUPPORT)
- add_definitions(-DASEPRITE_WITH_WEBP_SUPPORT)
+diff -uNr a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
+--- a/src/app/CMakeLists.txt 2022-01-12 15:10:33.000000000 +0100
++++ b/src/app/CMakeLists.txt 2022-01-18 15:06:41.357885045 +0100
+@@ -91,9 +91,6 @@
+ add_definitions(-DENABLE_WEBP)
endif()
-# libarchive definitions
@@ -40,7 +38,7 @@ index a9e80d73c..619acac92 100644
######################################################################
# app-lib target
-@@ -551,7 +548,7 @@ target_link_libraries(app-lib
+@@ -669,7 +666,7 @@
${FREETYPE_LIBRARIES}
${HARFBUZZ_LIBRARIES}
json11
@@ -49,18 +47,20 @@ index a9e80d73c..619acac92 100644
fmt
tinyexpr)
-diff --git a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
-index 596ffa2e4..977816439 100644
---- a/third_party/CMakeLists.txt
-+++ b/third_party/CMakeLists.txt
-@@ -105,19 +105,21 @@ endif()
+diff -uNr a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
+--- a/third_party/CMakeLists.txt 2022-01-12 15:10:34.000000000 +0100
++++ b/third_party/CMakeLists.txt 2022-01-18 15:06:41.357885045 +0100
+@@ -119,22 +119,24 @@
add_subdirectory(json11)
# libarchive
-set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
-set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
-set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
+-set(ENABLE_LZ4 OFF CACHE BOOL "Enable the use of the system LZ4 library if found")
+-set(ENABLE_LZO OFF CACHE BOOL "Enable the use of the system LZO library if found")
-set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
+-set(ENABLE_ZSTD OFF CACHE BOOL "Enable the use of the system zstd library if found")
-set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
-set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
-set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
@@ -74,7 +74,10 @@ index 596ffa2e4..977816439 100644
+ set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
+ set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
+ set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
++ set(ENABLE_LZ4 OFF CACHE BOOL "Enable the use of the system LZ4 library if found")
++ set(ENABLE_LZO OFF CACHE BOOL "Enable the use of the system LZO library if found")
+ set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
++ set(ENABLE_ZSTD OFF CACHE BOOL "Enable the use of the system zstd library if found")
+ set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
+ set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
+ set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
diff --git a/dev-games/aseprite/files/aseprite-1.2.29-system_libwebp.patch b/dev-games/aseprite/files/aseprite-1.2.33-system_libwebp.patch
index 896e03e..161e4f8 100644
--- a/dev-games/aseprite/files/aseprite-1.2.29-system_libwebp.patch
+++ b/dev-games/aseprite/files/aseprite-1.2.33-system_libwebp.patch
@@ -1,7 +1,7 @@
diff -uNr a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2020-03-06 18:47:37.000000000 +0100
-+++ b/CMakeLists.txt 2020-04-14 09:25:00.270728334 +0200
-@@ -66,6 +66,7 @@
+--- a/CMakeLists.txt 2022-01-12 15:10:33.000000000 +0100
++++ b/CMakeLists.txt 2022-02-15 18:39:49.384093189 +0100
+@@ -62,6 +62,7 @@
option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
option(USE_SHARED_FREETYPE "Use shared FreeType library" off)
option(USE_SHARED_HARFBUZZ "Use shared HarfBuzz library" off)
@@ -9,15 +9,18 @@ diff -uNr a/CMakeLists.txt b/CMakeLists.txt
option(ENABLE_ASEPRITE_EXE "Compile main Aseprite executable" on)
option(ENABLE_MEMLEAK "Enable memory-leaks detector (only for developers)" off)
option(ENABLE_NEWS "Enable the news in Home tab" on)
-@@ -229,9 +230,14 @@
+@@ -235,9 +236,17 @@
# libwebp
- if(WITH_WEBP_SUPPORT)
+ if(ENABLE_WEBP)
- set(WEBP_LIBRARIES webp webpdemux libwebpmux)
- set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
- include_directories(${WEBP_INCLUDE_DIR})
+ if(USE_SHARED_WEBP)
-+ find_library(WEBP_LIBRARIES NAMES webp)
++ find_library(WEBP_LIBRARY NAMES webp)
++ find_library(WEBPDEMUX_LIBRARY NAMES webpdemux)
++ find_library(WEBPMUX_LIBRARY NAMES webpmux)
++ set(WEBP_LIBRARIES ${WEBP_LIBRARY} ${WEBPDEMUX_LIBRARY} ${WEBPMUX_LIBRARY})
+ find_path(WEBP_INCLUDE_DIRS NAMES decode.h PATH_SUFFIXES webp)
+ else()
+ set(WEBP_LIBRARIES webp webpdemux libwebpmux)
@@ -28,14 +31,14 @@ diff -uNr a/CMakeLists.txt b/CMakeLists.txt
# tinyxml
diff -uNr a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
---- a/third_party/CMakeLists.txt 2019-10-24 01:54:06.000000000 +0200
-+++ b/third_party/CMakeLists.txt 2020-04-14 09:22:20.799744576 +0200
-@@ -32,7 +32,7 @@
+--- a/third_party/CMakeLists.txt 2022-01-12 15:10:34.000000000 +0100
++++ b/third_party/CMakeLists.txt 2022-02-15 18:39:26.632093684 +0100
+@@ -33,7 +33,7 @@
add_subdirectory(giflib)
endif()
--if(WITH_WEBP_SUPPORT)
-+if(WITH_WEBP_SUPPORT AND NOT USE_SHARED_WEBP)
+-if(ENABLE_WEBP)
++if(ENABLE_WEBP AND NOT USE_SHARED_WEBP)
set(WEBP_BUILD_EXTRAS OFF CACHE BOOL "Build extras.")
- add_subdirectory(libwebp)
- endif()
+ set(WEBP_BUILD_ANIM_UTILS OFF CACHE BOOL "Build animation utilities.")
+ set(WEBP_BUILD_CWEBP OFF CACHE BOOL "Build the cwebp command line tool.")