summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/aseprite/files')
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.21-system_libarchive.patch84
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.21-system_libwebp.patch41
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.30-system_libarchive.patch90
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.30-system_libwebp.patch41
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.34.1-system_harfbuzz.patch23
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.34.1-system_libarchive.patch93
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.34.1-system_libwebp.patch44
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.35-system_harfbuzz.patch23
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.35-system_libarchive.patch97
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.35-system_libwebp.patch44
10 files changed, 0 insertions, 580 deletions
diff --git a/dev-games/aseprite/files/aseprite-1.2.21-system_libarchive.patch b/dev-games/aseprite/files/aseprite-1.2.21-system_libarchive.patch
deleted file mode 100644
index c032508..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.21-system_libarchive.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dae638be8..dd5d17794 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -60,6 +60,7 @@ option(USE_SHARED_CURL "Use your installed copy of curl" off)
- option(USE_SHARED_GIFLIB "Use your installed copy of giflib" off)
- option(USE_SHARED_JPEGLIB "Use your installed copy of jpeglib" off)
- option(USE_SHARED_ZLIB "Use your installed copy of zlib" off)
-+option(USE_SHARED_LIBARCHIVE "Use your installed copy of libarchive" off)
- option(USE_SHARED_LIBPNG "Use your installed copy of libpng" off)
- option(USE_SHARED_TINYXML "Use your installed copy of tinyxml" off)
- option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
-@@ -202,6 +202,15 @@ else()
- endif()
- include_directories(${ZLIB_INCLUDE_DIRS})
-
-+# libarchive
-+if(USE_SHARED_LIBARCHIVE)
-+ find_library(ARCHIVE_LIBRARIES NAMES archive)
-+ find_path(ARCHIVE_INCLUDE_DIRS NAMES archive.h)
-+else()
-+ add_definitions(-DLIBARCHIVE_STATIC)
-+ set(ARCHIVE_LIBRARIES archive_static)
-+endif()
-+
- # libpng
- if(USE_SHARED_LIBPNG)
- find_package(PNG REQUIRED)
-diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
-index a9e80d73c..619acac92 100644
---- a/src/app/CMakeLists.txt
-+++ b/src/app/CMakeLists.txt
-@@ -91,9 +91,6 @@ if(WITH_WEBP_SUPPORT)
- add_definitions(-DASEPRITE_WITH_WEBP_SUPPORT)
- endif()
-
--# libarchive definitions
--add_definitions(-DLIBARCHIVE_STATIC)
--
- ######################################################################
- # app-lib target
-
-@@ -551,7 +548,7 @@ target_link_libraries(app-lib
- ${FREETYPE_LIBRARIES}
- ${HARFBUZZ_LIBRARIES}
- json11
-- archive_static
-+ ${ARCHIVE_LIBRARIES}
- fmt
- tinyexpr)
-
-diff --git a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
-index 596ffa2e4..977816439 100644
---- a/third_party/CMakeLists.txt
-+++ b/third_party/CMakeLists.txt
-@@ -105,16 +105,18 @@ endif()
- add_subdirectory(json11)
-
- # libarchive
--set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
--set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
--set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
--set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
--set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
--set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
--set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
--add_subdirectory(libarchive)
--target_include_directories(archive_static INTERFACE
-- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
-+if(NOT USE_SHARED_LIBARCHIVE)
-+ set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
-+ set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
-+ set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
-+ set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
-+ set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
-+ set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
-+ set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
-+ add_subdirectory(libarchive)
-+ target_include_directories(archive_static INTERFACE
-+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
-+endif()
-
- # benchmark
- if(ENABLE_BENCHMARKS)
diff --git a/dev-games/aseprite/files/aseprite-1.2.21-system_libwebp.patch b/dev-games/aseprite/files/aseprite-1.2.21-system_libwebp.patch
deleted file mode 100644
index 896e03e..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.21-system_libwebp.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -uNr a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2020-03-06 18:47:37.000000000 +0100
-+++ b/CMakeLists.txt 2020-04-14 09:25:00.270728334 +0200
-@@ -66,6 +66,7 @@
- option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
- option(USE_SHARED_FREETYPE "Use shared FreeType library" off)
- option(USE_SHARED_HARFBUZZ "Use shared HarfBuzz library" off)
-+option(USE_SHARED_WEBP "Use your installed copy of webp" off)
- option(ENABLE_ASEPRITE_EXE "Compile main Aseprite executable" on)
- option(ENABLE_MEMLEAK "Enable memory-leaks detector (only for developers)" off)
- option(ENABLE_NEWS "Enable the news in Home tab" on)
-@@ -229,9 +230,14 @@
-
- # libwebp
- if(WITH_WEBP_SUPPORT)
-- set(WEBP_LIBRARIES webp webpdemux libwebpmux)
-- set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
-- include_directories(${WEBP_INCLUDE_DIR})
-+ if(USE_SHARED_WEBP)
-+ find_library(WEBP_LIBRARIES NAMES webp)
-+ find_path(WEBP_INCLUDE_DIRS NAMES decode.h PATH_SUFFIXES webp)
-+ else()
-+ set(WEBP_LIBRARIES webp webpdemux libwebpmux)
-+ set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
-+ include_directories(${WEBP_INCLUDE_DIR})
-+ endif()
- endif()
-
- # tinyxml
-diff -uNr a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
---- a/third_party/CMakeLists.txt 2019-10-24 01:54:06.000000000 +0200
-+++ b/third_party/CMakeLists.txt 2020-04-14 09:22:20.799744576 +0200
-@@ -32,7 +32,7 @@
- add_subdirectory(giflib)
- endif()
-
--if(WITH_WEBP_SUPPORT)
-+if(WITH_WEBP_SUPPORT AND NOT USE_SHARED_WEBP)
- set(WEBP_BUILD_EXTRAS OFF CACHE BOOL "Build extras.")
- add_subdirectory(libwebp)
- endif()
diff --git a/dev-games/aseprite/files/aseprite-1.2.30-system_libarchive.patch b/dev-games/aseprite/files/aseprite-1.2.30-system_libarchive.patch
deleted file mode 100644
index 2434840..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.30-system_libarchive.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dae638be8..dd5d17794 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -60,6 +60,7 @@ option(USE_SHARED_CURL "Use your installed copy of curl" off)
- option(USE_SHARED_GIFLIB "Use your installed copy of giflib" off)
- option(USE_SHARED_JPEGLIB "Use your installed copy of jpeglib" off)
- option(USE_SHARED_ZLIB "Use your installed copy of zlib" off)
-+option(USE_SHARED_LIBARCHIVE "Use your installed copy of libarchive" off)
- option(USE_SHARED_LIBPNG "Use your installed copy of libpng" off)
- option(USE_SHARED_TINYXML "Use your installed copy of tinyxml" off)
- option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
-@@ -202,6 +202,15 @@ else()
- endif()
- include_directories(${ZLIB_INCLUDE_DIRS})
-
-+# libarchive
-+if(USE_SHARED_LIBARCHIVE)
-+ find_library(ARCHIVE_LIBRARIES NAMES archive)
-+ find_path(ARCHIVE_INCLUDE_DIRS NAMES archive.h)
-+else()
-+ add_definitions(-DLIBARCHIVE_STATIC)
-+ set(ARCHIVE_LIBRARIES archive_static)
-+endif()
-+
- # libpng
- if(USE_SHARED_LIBPNG)
- find_package(PNG REQUIRED)
-diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
-index a9e80d73c..619acac92 100644
---- a/src/app/CMakeLists.txt
-+++ b/src/app/CMakeLists.txt
-@@ -91,9 +91,6 @@ if(WITH_WEBP_SUPPORT)
- add_definitions(-DASEPRITE_WITH_WEBP_SUPPORT)
- endif()
-
--# libarchive definitions
--add_definitions(-DLIBARCHIVE_STATIC)
--
- ######################################################################
- # app-lib target
-
-@@ -551,7 +548,7 @@ target_link_libraries(app-lib
- ${FREETYPE_LIBRARIES}
- ${HARFBUZZ_LIBRARIES}
- json11
-- archive_static
-+ ${ARCHIVE_LIBRARIES}
- fmt
- tinyexpr)
-
-diff --git a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
-index 596ffa2e4..977816439 100644
---- a/third_party/CMakeLists.txt
-+++ b/third_party/CMakeLists.txt
-@@ -105,19 +105,21 @@ endif()
- add_subdirectory(json11)
-
- # libarchive
--set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
--set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
--set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
--set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
--set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
--set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
--set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
--set(ENABLE_CAT OFF CACHE BOOL "Enable cat building")
--set(ENABLE_TAR OFF CACHE BOOL "Enable tar building")
--set(ENABLE_CPIO OFF CACHE BOOL "Enable cpio building")
--add_subdirectory(libarchive)
--target_include_directories(archive_static INTERFACE
-- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
-+if(NOT USE_SHARED_LIBARCHIVE)
-+ set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
-+ set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
-+ set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
-+ set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
-+ set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
-+ set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
-+ set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
-+ set(ENABLE_CAT OFF CACHE BOOL "Enable cat building")
-+ set(ENABLE_TAR OFF CACHE BOOL "Enable tar building")
-+ set(ENABLE_CPIO OFF CACHE BOOL "Enable cpio building")
-+ add_subdirectory(libarchive)
-+ target_include_directories(archive_static INTERFACE
-+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
-+endif()
-
- # benchmark
- if(ENABLE_BENCHMARKS)
diff --git a/dev-games/aseprite/files/aseprite-1.2.30-system_libwebp.patch b/dev-games/aseprite/files/aseprite-1.2.30-system_libwebp.patch
deleted file mode 100644
index 896e03e..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.30-system_libwebp.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -uNr a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2020-03-06 18:47:37.000000000 +0100
-+++ b/CMakeLists.txt 2020-04-14 09:25:00.270728334 +0200
-@@ -66,6 +66,7 @@
- option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
- option(USE_SHARED_FREETYPE "Use shared FreeType library" off)
- option(USE_SHARED_HARFBUZZ "Use shared HarfBuzz library" off)
-+option(USE_SHARED_WEBP "Use your installed copy of webp" off)
- option(ENABLE_ASEPRITE_EXE "Compile main Aseprite executable" on)
- option(ENABLE_MEMLEAK "Enable memory-leaks detector (only for developers)" off)
- option(ENABLE_NEWS "Enable the news in Home tab" on)
-@@ -229,9 +230,14 @@
-
- # libwebp
- if(WITH_WEBP_SUPPORT)
-- set(WEBP_LIBRARIES webp webpdemux libwebpmux)
-- set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
-- include_directories(${WEBP_INCLUDE_DIR})
-+ if(USE_SHARED_WEBP)
-+ find_library(WEBP_LIBRARIES NAMES webp)
-+ find_path(WEBP_INCLUDE_DIRS NAMES decode.h PATH_SUFFIXES webp)
-+ else()
-+ set(WEBP_LIBRARIES webp webpdemux libwebpmux)
-+ set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
-+ include_directories(${WEBP_INCLUDE_DIR})
-+ endif()
- endif()
-
- # tinyxml
-diff -uNr a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
---- a/third_party/CMakeLists.txt 2019-10-24 01:54:06.000000000 +0200
-+++ b/third_party/CMakeLists.txt 2020-04-14 09:22:20.799744576 +0200
-@@ -32,7 +32,7 @@
- add_subdirectory(giflib)
- endif()
-
--if(WITH_WEBP_SUPPORT)
-+if(WITH_WEBP_SUPPORT AND NOT USE_SHARED_WEBP)
- set(WEBP_BUILD_EXTRAS OFF CACHE BOOL "Build extras.")
- add_subdirectory(libwebp)
- endif()
diff --git a/dev-games/aseprite/files/aseprite-1.2.34.1-system_harfbuzz.patch b/dev-games/aseprite/files/aseprite-1.2.34.1-system_harfbuzz.patch
deleted file mode 100644
index f7c8543..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.34.1-system_harfbuzz.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -uNr a/laf/CMakeLists.txt b/laf/CMakeLists.txt
---- a/laf/CMakeLists.txt 2021-12-01 22:06:08.000000000 +0100
-+++ b/laf/CMakeLists.txt 2022-02-15 18:05:31.640137967 +0100
-@@ -44,13 +44,12 @@
- # Find libraries
- if(LAF_BACKEND STREQUAL "skia")
- include(FindSkia)
--else()
-- if(NOT FREETYPE_LIBRARIES)
-- find_package(Freetype)
-- endif()
-- if(NOT HARFBUZZ_LIBRARIES)
-- find_package(HarfBuzz)
-- endif()
-+endif()
-+if(NOT FREETYPE_LIBRARIES)
-+ find_package(Freetype)
-+endif()
-+if(NOT HARFBUZZ_LIBRARIES)
-+ find_package(HarfBuzz)
- endif()
-
- add_subdirectory(third_party)
diff --git a/dev-games/aseprite/files/aseprite-1.2.34.1-system_libarchive.patch b/dev-games/aseprite/files/aseprite-1.2.34.1-system_libarchive.patch
deleted file mode 100644
index 8b23f45..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.34.1-system_libarchive.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-diff -uNr a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2022-01-12 15:10:33.000000000 +0100
-+++ b/CMakeLists.txt 2022-01-18 15:06:41.357885045 +0100
-@@ -57,6 +57,7 @@
- option(USE_SHARED_GIFLIB "Use your installed copy of giflib" off)
- option(USE_SHARED_JPEGLIB "Use your installed copy of jpeglib" off)
- option(USE_SHARED_ZLIB "Use your installed copy of zlib" off)
-+option(USE_SHARED_LIBARCHIVE "Use your installed copy of libarchive" off)
- option(USE_SHARED_LIBPNG "Use your installed copy of libpng" off)
- option(USE_SHARED_TINYXML "Use your installed copy of tinyxml" off)
- option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
-@@ -216,6 +217,15 @@
- endif()
- include_directories(${ZLIB_INCLUDE_DIRS})
-
-+# libarchive
-+if(USE_SHARED_LIBARCHIVE)
-+ find_library(ARCHIVE_LIBRARIES NAMES archive)
-+ find_path(ARCHIVE_INCLUDE_DIRS NAMES archive.h)
-+else()
-+ add_definitions(-DLIBARCHIVE_STATIC)
-+ set(ARCHIVE_LIBRARIES archive_static)
-+endif()
-+
- # libpng
- if(USE_SHARED_LIBPNG)
- find_package(PNG REQUIRED)
-diff -uNr a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
---- a/src/app/CMakeLists.txt 2022-01-12 15:10:33.000000000 +0100
-+++ b/src/app/CMakeLists.txt 2022-01-18 15:06:41.357885045 +0100
-@@ -91,9 +91,6 @@
- add_definitions(-DENABLE_WEBP)
- endif()
-
--# libarchive definitions
--add_definitions(-DLIBARCHIVE_STATIC)
--
- ######################################################################
- # app-lib target
-
-@@ -669,7 +666,7 @@
- ${FREETYPE_LIBRARIES}
- ${HARFBUZZ_LIBRARIES}
- json11
-- archive_static
-+ ${ARCHIVE_LIBRARIES}
- fmt
- tinyexpr)
-
-diff -uNr a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
---- a/third_party/CMakeLists.txt 2022-01-12 15:10:34.000000000 +0100
-+++ b/third_party/CMakeLists.txt 2022-01-18 15:06:41.357885045 +0100
-@@ -119,22 +119,24 @@
- add_subdirectory(json11)
-
- # libarchive
--set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
--set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
--set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
--set(ENABLE_LZ4 OFF CACHE BOOL "Enable the use of the system LZ4 library if found")
--set(ENABLE_LZO OFF CACHE BOOL "Enable the use of the system LZO library if found")
--set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
--set(ENABLE_ZSTD OFF CACHE BOOL "Enable the use of the system zstd library if found")
--set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
--set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
--set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
--set(ENABLE_CAT OFF CACHE BOOL "Enable cat building")
--set(ENABLE_TAR OFF CACHE BOOL "Enable tar building")
--set(ENABLE_CPIO OFF CACHE BOOL "Enable cpio building")
--add_subdirectory(libarchive)
--target_include_directories(archive_static INTERFACE
-- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
-+if(NOT USE_SHARED_LIBARCHIVE)
-+ set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
-+ set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
-+ set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
-+ set(ENABLE_LZ4 OFF CACHE BOOL "Enable the use of the system LZ4 library if found")
-+ set(ENABLE_LZO OFF CACHE BOOL "Enable the use of the system LZO library if found")
-+ set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
-+ set(ENABLE_ZSTD OFF CACHE BOOL "Enable the use of the system zstd library if found")
-+ set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
-+ set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
-+ set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
-+ set(ENABLE_CAT OFF CACHE BOOL "Enable cat building")
-+ set(ENABLE_TAR OFF CACHE BOOL "Enable tar building")
-+ set(ENABLE_CPIO OFF CACHE BOOL "Enable cpio building")
-+ add_subdirectory(libarchive)
-+ target_include_directories(archive_static INTERFACE
-+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
-+endif()
-
- # benchmark
- if(ENABLE_BENCHMARKS)
diff --git a/dev-games/aseprite/files/aseprite-1.2.34.1-system_libwebp.patch b/dev-games/aseprite/files/aseprite-1.2.34.1-system_libwebp.patch
deleted file mode 100644
index 161e4f8..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.34.1-system_libwebp.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -uNr a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2022-01-12 15:10:33.000000000 +0100
-+++ b/CMakeLists.txt 2022-02-15 18:39:49.384093189 +0100
-@@ -62,6 +62,7 @@
- option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
- option(USE_SHARED_FREETYPE "Use shared FreeType library" off)
- option(USE_SHARED_HARFBUZZ "Use shared HarfBuzz library" off)
-+option(USE_SHARED_WEBP "Use your installed copy of webp" off)
- option(ENABLE_ASEPRITE_EXE "Compile main Aseprite executable" on)
- option(ENABLE_MEMLEAK "Enable memory-leaks detector (only for developers)" off)
- option(ENABLE_NEWS "Enable the news in Home tab" on)
-@@ -235,9 +236,17 @@
-
- # libwebp
- if(ENABLE_WEBP)
-- set(WEBP_LIBRARIES webp webpdemux libwebpmux)
-- set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
-- include_directories(${WEBP_INCLUDE_DIR})
-+ if(USE_SHARED_WEBP)
-+ find_library(WEBP_LIBRARY NAMES webp)
-+ find_library(WEBPDEMUX_LIBRARY NAMES webpdemux)
-+ find_library(WEBPMUX_LIBRARY NAMES webpmux)
-+ set(WEBP_LIBRARIES ${WEBP_LIBRARY} ${WEBPDEMUX_LIBRARY} ${WEBPMUX_LIBRARY})
-+ find_path(WEBP_INCLUDE_DIRS NAMES decode.h PATH_SUFFIXES webp)
-+ else()
-+ set(WEBP_LIBRARIES webp webpdemux libwebpmux)
-+ set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
-+ include_directories(${WEBP_INCLUDE_DIR})
-+ endif()
- endif()
-
- # tinyxml
-diff -uNr a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
---- a/third_party/CMakeLists.txt 2022-01-12 15:10:34.000000000 +0100
-+++ b/third_party/CMakeLists.txt 2022-02-15 18:39:26.632093684 +0100
-@@ -33,7 +33,7 @@
- add_subdirectory(giflib)
- endif()
-
--if(ENABLE_WEBP)
-+if(ENABLE_WEBP AND NOT USE_SHARED_WEBP)
- set(WEBP_BUILD_EXTRAS OFF CACHE BOOL "Build extras.")
- set(WEBP_BUILD_ANIM_UTILS OFF CACHE BOOL "Build animation utilities.")
- set(WEBP_BUILD_CWEBP OFF CACHE BOOL "Build the cwebp command line tool.")
diff --git a/dev-games/aseprite/files/aseprite-1.2.35-system_harfbuzz.patch b/dev-games/aseprite/files/aseprite-1.2.35-system_harfbuzz.patch
deleted file mode 100644
index f7c8543..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.35-system_harfbuzz.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -uNr a/laf/CMakeLists.txt b/laf/CMakeLists.txt
---- a/laf/CMakeLists.txt 2021-12-01 22:06:08.000000000 +0100
-+++ b/laf/CMakeLists.txt 2022-02-15 18:05:31.640137967 +0100
-@@ -44,13 +44,12 @@
- # Find libraries
- if(LAF_BACKEND STREQUAL "skia")
- include(FindSkia)
--else()
-- if(NOT FREETYPE_LIBRARIES)
-- find_package(Freetype)
-- endif()
-- if(NOT HARFBUZZ_LIBRARIES)
-- find_package(HarfBuzz)
-- endif()
-+endif()
-+if(NOT FREETYPE_LIBRARIES)
-+ find_package(Freetype)
-+endif()
-+if(NOT HARFBUZZ_LIBRARIES)
-+ find_package(HarfBuzz)
- endif()
-
- add_subdirectory(third_party)
diff --git a/dev-games/aseprite/files/aseprite-1.2.35-system_libarchive.patch b/dev-games/aseprite/files/aseprite-1.2.35-system_libarchive.patch
deleted file mode 100644
index 699d3bd..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.35-system_libarchive.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-diff -uNr a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2022-01-12 15:10:33.000000000 +0100
-+++ b/CMakeLists.txt 2022-01-18 15:06:41.357885045 +0100
-@@ -57,6 +57,7 @@
- option(USE_SHARED_GIFLIB "Use your installed copy of giflib" off)
- option(USE_SHARED_JPEGLIB "Use your installed copy of jpeglib" off)
- option(USE_SHARED_ZLIB "Use your installed copy of zlib" off)
-+option(USE_SHARED_LIBARCHIVE "Use your installed copy of libarchive" off)
- option(USE_SHARED_LIBPNG "Use your installed copy of libpng" off)
- option(USE_SHARED_TINYXML "Use your installed copy of tinyxml" off)
- option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
-@@ -216,6 +217,15 @@
- endif()
- include_directories(${ZLIB_INCLUDE_DIRS})
-
-+# libarchive
-+if(USE_SHARED_LIBARCHIVE)
-+ find_library(ARCHIVE_LIBRARIES NAMES archive)
-+ find_path(ARCHIVE_INCLUDE_DIRS NAMES archive.h)
-+else()
-+ add_definitions(-DLIBARCHIVE_STATIC)
-+ set(ARCHIVE_LIBRARIES archive_static)
-+endif()
-+
- # libpng
- if(USE_SHARED_LIBPNG)
- find_package(PNG REQUIRED)
-diff -uNr a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
---- a/src/app/CMakeLists.txt 2022-01-12 15:10:33.000000000 +0100
-+++ b/src/app/CMakeLists.txt 2022-01-18 15:06:41.357885045 +0100
-@@ -91,9 +91,6 @@
- add_definitions(-DENABLE_WEBP)
- endif()
-
--# libarchive definitions
--add_definitions(-DLIBARCHIVE_STATIC)
--
- ######################################################################
- # app-lib target
-
-@@ -669,7 +666,7 @@
- ${FREETYPE_LIBRARIES}
- ${HARFBUZZ_LIBRARIES}
- json11
-- archive_static
-+ ${ARCHIVE_LIBRARIES}
- fmt
- tinyexpr)
-
-diff -uNr a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
---- a/third_party/CMakeLists.txt 2022-01-12 15:10:34.000000000 +0100
-+++ b/third_party/CMakeLists.txt 2022-01-18 15:06:41.357885045 +0100
-@@ -119,24 +119,26 @@
- add_subdirectory(json11)
-
- # libarchive
--set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
--set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
--set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
--set(ENABLE_LZ4 OFF CACHE BOOL "Enable the use of the system LZ4 library if found")
--set(ENABLE_LZO OFF CACHE BOOL "Enable the use of the system LZO library if found")
--set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
--set(ENABLE_ZSTD OFF CACHE BOOL "Enable the use of the system zstd library if found")
--set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
--set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
--set(ENABLE_EXPAT OFF CACHE BOOL "Enable the use of the system EXPAT library if found")
--set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
--set(ENABLE_CAT OFF CACHE BOOL "Enable cat building")
--set(ENABLE_TAR OFF CACHE BOOL "Enable tar building")
--set(ENABLE_CPIO OFF CACHE BOOL "Enable cpio building")
--set(ENABLE_LIBB2 OFF CACHE BOOL "Enable the use of the system LIBB2 library if found")
--add_subdirectory(libarchive)
--target_include_directories(archive_static INTERFACE
-- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
-+if(NOT USE_SHARED_LIBARCHIVE)
-+ set(ENABLE_WERROR OFF CACHE BOOL "Treat warnings as errors - default is ON for Debug, OFF otherwise.")
-+ set(ENABLE_TEST OFF CACHE BOOL "Enable unit and regression tests")
-+ set(ENABLE_COVERAGE OFF CACHE BOOL "Enable code coverage (GCC only, automatically sets ENABLE_TEST to ON)")
-+ set(ENABLE_LZ4 OFF CACHE BOOL "Enable the use of the system LZ4 library if found")
-+ set(ENABLE_LZO OFF CACHE BOOL "Enable the use of the system LZO library if found")
-+ set(ENABLE_LZMA OFF CACHE BOOL "Enable the use of the system LZMA library if found")
-+ set(ENABLE_ZSTD OFF CACHE BOOL "Enable the use of the system zstd library if found")
-+ set(ENABLE_CNG OFF CACHE BOOL "Enable the use of CNG(Crypto Next Generation)")
-+ set(ENABLE_BZip2 OFF CACHE BOOL "Enable the use of the system BZip2 library if found")
-+ set(ENABLE_EXPAT OFF CACHE BOOL "Enable the use of the system EXPAT library if found")
-+ set(ENABLE_LIBXML2 OFF CACHE BOOL "Enable the use of the system libxml2 library if found")
-+ set(ENABLE_CAT OFF CACHE BOOL "Enable cat building")
-+ set(ENABLE_TAR OFF CACHE BOOL "Enable tar building")
-+ set(ENABLE_CPIO OFF CACHE BOOL "Enable cpio building")
-+ set(ENABLE_LIBB2 OFF CACHE BOOL "Enable the use of the system LIBB2 library if found")
-+ add_subdirectory(libarchive)
-+ target_include_directories(archive_static INTERFACE
-+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/libarchive/libarchive>)
-+endif()
-
- # benchmark
- if(ENABLE_BENCHMARKS)
diff --git a/dev-games/aseprite/files/aseprite-1.2.35-system_libwebp.patch b/dev-games/aseprite/files/aseprite-1.2.35-system_libwebp.patch
deleted file mode 100644
index 161e4f8..0000000
--- a/dev-games/aseprite/files/aseprite-1.2.35-system_libwebp.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -uNr a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2022-01-12 15:10:33.000000000 +0100
-+++ b/CMakeLists.txt 2022-02-15 18:39:49.384093189 +0100
-@@ -62,6 +62,7 @@
- option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
- option(USE_SHARED_FREETYPE "Use shared FreeType library" off)
- option(USE_SHARED_HARFBUZZ "Use shared HarfBuzz library" off)
-+option(USE_SHARED_WEBP "Use your installed copy of webp" off)
- option(ENABLE_ASEPRITE_EXE "Compile main Aseprite executable" on)
- option(ENABLE_MEMLEAK "Enable memory-leaks detector (only for developers)" off)
- option(ENABLE_NEWS "Enable the news in Home tab" on)
-@@ -235,9 +236,17 @@
-
- # libwebp
- if(ENABLE_WEBP)
-- set(WEBP_LIBRARIES webp webpdemux libwebpmux)
-- set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
-- include_directories(${WEBP_INCLUDE_DIR})
-+ if(USE_SHARED_WEBP)
-+ find_library(WEBP_LIBRARY NAMES webp)
-+ find_library(WEBPDEMUX_LIBRARY NAMES webpdemux)
-+ find_library(WEBPMUX_LIBRARY NAMES webpmux)
-+ set(WEBP_LIBRARIES ${WEBP_LIBRARY} ${WEBPDEMUX_LIBRARY} ${WEBPMUX_LIBRARY})
-+ find_path(WEBP_INCLUDE_DIRS NAMES decode.h PATH_SUFFIXES webp)
-+ else()
-+ set(WEBP_LIBRARIES webp webpdemux libwebpmux)
-+ set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
-+ include_directories(${WEBP_INCLUDE_DIR})
-+ endif()
- endif()
-
- # tinyxml
-diff -uNr a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
---- a/third_party/CMakeLists.txt 2022-01-12 15:10:34.000000000 +0100
-+++ b/third_party/CMakeLists.txt 2022-02-15 18:39:26.632093684 +0100
-@@ -33,7 +33,7 @@
- add_subdirectory(giflib)
- endif()
-
--if(ENABLE_WEBP)
-+if(ENABLE_WEBP AND NOT USE_SHARED_WEBP)
- set(WEBP_BUILD_EXTRAS OFF CACHE BOOL "Build extras.")
- set(WEBP_BUILD_ANIM_UTILS OFF CACHE BOOL "Build animation utilities.")
- set(WEBP_BUILD_CWEBP OFF CACHE BOOL "Build the cwebp command line tool.")