aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-06-02 07:53:25 +0300
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-06-02 07:53:25 +0300
commitdbc793c755b7b51a08a94bce9c99921bfc6828ae (patch)
tree6d2a5d3d3e3642cb009a592d3eba51ead3e1db19
parentdev-util/dlang-tools: enable gdc-14 (diff)
downloaddlang-dbc793c755b7b51a08a94bce9c99921bfc6828ae.tar.gz
dlang-dbc793c755b7b51a08a94bce9c99921bfc6828ae.tar.bz2
dlang-dbc793c755b7b51a08a94bce9c99921bfc6828ae.zip
dev-util/dscanner: enable gdc-14
Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
-rw-r--r--dev-util/dscanner/dscanner-0.16.0_beta4.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/dscanner/dscanner-0.16.0_beta4.ebuild b/dev-util/dscanner/dscanner-0.16.0_beta4.ebuild
index a82eb86..e07408f 100644
--- a/dev-util/dscanner/dscanner-0.16.0_beta4.ebuild
+++ b/dev-util/dscanner/dscanner-0.16.0_beta4.ebuild
@@ -34,7 +34,7 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="debug test"
RESTRICT="!test? ( test )"
-DLANG_COMPAT=( dmd-2_{106..108} gdc-13 ldc2-1_{35..38} )
+DLANG_COMPAT=( dmd-2_{106..108} gdc-1{3,4} ldc2-1_{35..38} )
inherit dlang-single
@@ -58,7 +58,7 @@ src_prepare() {
}
src_compile() {
- if [[ ${EDC} == gdc* && ${DCFLAGS} == *-march=native* ]]; then
+ if [[ ${EDC} == gdc-13 && ${DCFLAGS} == *-march=native* ]]; then
# At this point I wonder if we should have been stripping it in the eclass.
# Fixed for >=sys-devel/gcc-13.2.1_p20240330
ewarn '-march=native has been removed from your flags.'