aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2017-05-10 09:30:08 +0200
committerMarco Leise <marco.leise@gmx.de>2017-05-10 20:39:22 +0200
commit762aadce18e9f79f70d505aa8abca9b9dd5401d2 (patch)
tree60012c902bdf38c0a107e8ee72b953688ca54d9b /dev-libs
parentAdded D-Scanner 0.4.0. (diff)
downloaddlang-762aadce18e9f79f70d505aa8abca9b9dd5401d2.tar.gz
dlang-762aadce18e9f79f70d505aa8abca9b9dd5401d2.tar.bz2
dlang-762aadce18e9f79f70d505aa8abca9b9dd5401d2.zip
Fix non-fatal undefined references (to libgtk-3.so) in the optional GtkD 3 libraries.
This occured to me when attempting to prelink Tilix.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gtkd/gtkd-3.5.1-r2.ebuild (renamed from dev-libs/gtkd/gtkd-3.5.1-r1.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-libs/gtkd/gtkd-3.5.1-r1.ebuild b/dev-libs/gtkd/gtkd-3.5.1-r2.ebuild
index aeaa60c..a403497 100644
--- a/dev-libs/gtkd/gtkd-3.5.1-r1.ebuild
+++ b/dev-libs/gtkd/gtkd-3.5.1-r2.ebuild
@@ -42,8 +42,13 @@ d_src_compile() {
# Build the shared library version of the component
# The test phase expects no version extension on the .so
if dlang_has_shared_lib_support; then
+ # Avoid some undefined references in the optional libraries by linking against gtkd.
+ local lib
+ if [ "${LIB_NAME}" != "gtkd" ]; then
+ lib="${DLANG_LINKER_FLAG}-L. ${DLANG_LINKER_FLAG}-lgtkd-${MAJOR}"
+ fi
dlang_compile_lib_so lib${LIB_NAME}-${MAJOR}.so \
- lib${LIB_NAME}-${MAJOR}.so.0 -Isrc ${GTKD_SRC_DIRS[$i]}/*/*.d
+ lib${LIB_NAME}-${MAJOR}.so.0 -Isrc ${GTKD_SRC_DIRS[$i]}/*/*.d ${lib}
else
ewarn "${DC} does not have shared library support."
ewarn "Only static ${LIB_NAME} will be compiled if selected through the static-libs USE flag."