aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-06-25 10:27:52 +0200
committerGerion Entrup <gerion.entrup@flump.de>2024-06-30 23:07:04 +0200
commit6aeafb17e02c2cfe5c0918c5c8e9348a3c330fd7 (patch)
tree5b28cad706f9af0b764585ed2417e1c7d7aae81f
parentRevert "sys-devel/clang-toolchain-symlinks: Remove LLVM 14" (diff)
downloadgerislay-6aeafb17e02c2cfe5c0918c5c8e9348a3c330fd7.tar.gz
gerislay-6aeafb17e02c2cfe5c0918c5c8e9348a3c330fd7.tar.bz2
gerislay-6aeafb17e02c2cfe5c0918c5c8e9348a3c330fd7.zip
Revert "dev-python/clang-python: Remove LLVM 14"
This reverts commit f08b61da1ac71ed2f730054b772a8028f580d5c5. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--dev-python/clang-python/clang-python-14.0.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-14.0.6.ebuild b/dev-python/clang-python/clang-python-14.0.6.ebuild
new file mode 100644
index 0000000..2d5270c
--- /dev/null
+++ b/dev-python/clang-python/clang-python-14.0.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+DEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}