aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2019-05-02 13:36:32 +0200
committerGerion Entrup <gerion.entrup@flump.de>2019-05-24 12:47:40 +0200
commitaf228896374324d0bb52f03aee810490b2313603 (patch)
tree230bfad61207df9bbb663baa50b0a547754dbd55 /dev-python
parentmedia-plugins/hyperion: qt5 is mandatory (diff)
downloadgerislay-af228896374324d0bb52f03aee810490b2313603.tar.gz
gerislay-af228896374324d0bb52f03aee810490b2313603.tar.bz2
gerislay-af228896374324d0bb52f03aee810490b2313603.zip
dev-python/rauth: python 3.6 and 3.7 support
Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rauth/Manifest3
-rw-r--r--dev-python/rauth/files/rauth-0.7.2-fix-python-3.6.patch32
-rw-r--r--dev-python/rauth/rauth-0.7.2.ebuild6
3 files changed, 38 insertions, 3 deletions
diff --git a/dev-python/rauth/Manifest b/dev-python/rauth/Manifest
index b9c9340..ae64961 100644
--- a/dev-python/rauth/Manifest
+++ b/dev-python/rauth/Manifest
@@ -1,2 +1,3 @@
+AUX rauth-0.7.2-fix-python-3.6.patch 934 BLAKE2B 21f64e2b5e0e0ebe00d1d428770858b51fe4d617a306933ae273d01b96cfe76823161e1e86ec160f7d2f5dff299e3ff41adc774503ee575bab61e5605e59056f SHA512 c774c24c9a03603c9b319f370c416ac4472097914507f236a194a76a96ce5f4eddaf01ac0e212c8bd9bab099d8dbf0e5d870ceee665614394d703c02f23c0303
DIST rauth-0.7.2.tar.gz 34688 BLAKE2B 412b777d51e5682fec98088fc6af9cb799231deba7d9f808d61e0e6d57ff4f6f49c0e42dc1c6507f59053d603df85c5acd7105c76ce8c4ea02cc20c016402210 SHA512 8b2b0dd3b6878b928ca16b8ce2a264381cb465e7b2abcdae0bde3102dfd34e098606d7efc44ef5cfde0e89113044656df4f9fd7006c78d1300e02d321913cbb6
-EBUILD rauth-0.7.2.ebuild 545 BLAKE2B 3f426449ec56ea39acddc3e954641ddc5d2b18f0f7563a48e74d18a82c19003ff55a190692de5a171efaeb9a4635a691392a9fe2cd1f799eaabf478417bf8856 SHA512 5323d34dea752707d393edc4fc5355db508d5dfa4d5c11ef3860ba6cfd6339227c06aeca469cd4756a60d8484cd3cdb695d22cddc5d57351d2288716a2401246
+EBUILD rauth-0.7.2.ebuild 594 BLAKE2B 6aa0f1de46229320c864af8a7ccd14dc2bfce2c4c11f12745cc46d86abe620b12a59767d2167ae63fdabc90798ad09d8ac6cf0375fad856c342ed8f06f668ad6 SHA512 4a33bd98fc43ebecea91db2388a581e2095fdbec62af66d53d39bfdc25baa0a68037a00d52e7cca36f1e02f3c975b74a6e12c57930ac3578fadb91ab5a3b2139
diff --git a/dev-python/rauth/files/rauth-0.7.2-fix-python-3.6.patch b/dev-python/rauth/files/rauth-0.7.2-fix-python-3.6.patch
new file mode 100644
index 0000000..4c36238
--- /dev/null
+++ b/dev-python/rauth/files/rauth-0.7.2-fix-python-3.6.patch
@@ -0,0 +1,32 @@
+From 7b59a2587a2d08a012f49e904c86db59374e63eb Mon Sep 17 00:00:00 2001
+From: "J. Kevin Bay" <seregon@gmail.com>
+Date: Sat, 21 Jan 2017 22:10:07 -0500
+Subject: [PATCH] Bugfix for issue #195 (Python 3.6 support)
+
+---
+ rauth/utils.py | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/rauth/utils.py b/rauth/utils.py
+index b0b420a..6cdf5df 100644
+--- a/rauth/utils.py
++++ b/rauth/utils.py
+@@ -21,13 +21,12 @@ def absolute_url(url):
+
+
+ def parse_utf8_qsl(s):
+- d = dict(parse_qsl(s))
++ d = dict()
+
+- for k, v in d.items(): # pragma: no cover
++ for k, v in dict(parse_qsl(s)).items(): # pragma: no cover
+ if not isinstance(k, bytes) and not isinstance(v, bytes):
+ # skip this iteration if we have no keys or values to update
+ continue
+- d.pop(k)
+ if isinstance(k, bytes):
+ k = k.decode('utf-8')
+ if isinstance(v, bytes):
+--
+2.21.0
+
diff --git a/dev-python/rauth/rauth-0.7.2.ebuild b/dev-python/rauth/rauth-0.7.2.ebuild
index 2635e72..c0d0383 100644
--- a/dev-python/rauth/rauth-0.7.2.ebuild
+++ b/dev-python/rauth/rauth-0.7.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
DESCRIPTION="A Python library for OAuth 1.0/a, 2.0, and Ofly."
@@ -15,6 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+PATCHES=( "${FILESDIR}/${P}-fix-python-3.6.patch" )
+
DEPEND="
dev-python/requests[${PYTHON_USEDEP}]
test? ( dev-python/unittest2[${PYTHON_USEDEP}] )"