aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/organicmaps/files/no-dynamic-download.patch')
-rw-r--r--gui-apps/organicmaps/files/no-dynamic-download.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gui-apps/organicmaps/files/no-dynamic-download.patch b/gui-apps/organicmaps/files/no-dynamic-download.patch
new file mode 100644
index 0000000..eb7d021
--- /dev/null
+++ b/gui-apps/organicmaps/files/no-dynamic-download.patch
@@ -0,0 +1,15 @@
+diff --git a/transit/world_feed/world_feed_integration_tests/CMakeLists.txt b/transit/world_feed/world_feed_integration_tests/CMakeLists.txt
+index 9f945568d4..ec9755ab09 100644
+--- a/transit/world_feed/world_feed_integration_tests/CMakeLists.txt
++++ b/transit/world_feed/world_feed_integration_tests/CMakeLists.txt
+@@ -10,7 +10,9 @@ target_link_libraries(${PROJECT_NAME}
+ )
+
+ # This test requires additional data from the other repository
+-set(TEST_DATA_REPO_URL "https://github.com/organicmaps/world_feed_integration_tests_data.git")
++if(NOT TEST_DATA_REPO_URL)
++ set(TEST_DATA_REPO_URL "https://github.com/organicmaps/world_feed_integration_tests_data.git")
++endif()
+ set(DESTINATION_FOLDER "${OMIM_DATA_DIR}/world_feed_integration_tests_data/")
+
+ add_custom_command(