summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2023-06-28 19:00:39 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2023-06-28 19:00:39 -0400
commitd68bbb40754da56d9dd2f7f199d80c7b39501268 (patch)
tree7490d912c47ee62de5de281b12c99af34af0ead4
parentfix copywrite year, fix package paths, add Manifest hashes (diff)
downloadsuperposition-d68bbb40754da56d9dd2f7f199d80c7b39501268.tar.gz
superposition-d68bbb40754da56d9dd2f7f199d80c7b39501268.tar.bz2
superposition-d68bbb40754da56d9dd2f7f199d80c7b39501268.zip
add hyperbolica
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
-rw-r--r--games-puzzle/Hyperbolica/Hyperbolica-1.0.14.ebuild54
-rw-r--r--games-puzzle/Hyperbolica/Manifest3
-rw-r--r--games-puzzle/Hyperbolica/metadata.xml8
3 files changed, 65 insertions, 0 deletions
diff --git a/games-puzzle/Hyperbolica/Hyperbolica-1.0.14.ebuild b/games-puzzle/Hyperbolica/Hyperbolica-1.0.14.ebuild
new file mode 100644
index 0000000..5c07fda
--- /dev/null
+++ b/games-puzzle/Hyperbolica/Hyperbolica-1.0.14.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker
+
+DESCRIPTION="A true Non-Euclidean curved space like you've never experienced before!"
+HOMEPAGE="https://codeparade.itch.io/hyperbolica"
+SRC_URI="Hyperbolica-Linux-x64.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist fetch"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}
+ media-libs/mesa
+ sys-libs/glibc:2.2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+"
+BDEPEND=""
+
+QA_PREBUILT="opt/${PN}/UnityPlayer.so opt/${PN}/Hyperbolica_Data/Plugins/libsteam_api.so opt/${PN}/GameAssembly.so opt/${PN}/Hyperbolica.x86_64"
+
+pkg_nofetch() {
+ einfo ""
+ einfo "Please buy and download \"${A}\" from corresponding shop Itch.io"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo "You can get more info on ${HOMEPAGE}"
+ einfo ""
+}
+
+src_unpack() {
+ unpack_zip ${A}
+ mv "${PN}" "${S}" || die "mv failed"
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ insinto "${dir}"
+ exeinto "${dir}"
+
+ doins -r .
+ doexe Hyperbolica.x86_64 || die "Failed to install executables"
+
+ newicon "Hyperbolica_Data/Resources/UnityPlayer.png" "${PN}.png"
+ make_desktop_entry "${dir}/${PN}.x86_64" "Hyperbolica" "${PN}" || die "make_desktop_entry failed"
+}
diff --git a/games-puzzle/Hyperbolica/Manifest b/games-puzzle/Hyperbolica/Manifest
new file mode 100644
index 0000000..8dc49f9
--- /dev/null
+++ b/games-puzzle/Hyperbolica/Manifest
@@ -0,0 +1,3 @@
+DIST Hyperbolica-Linux-x64.zip 297502511 BLAKE2B 55677e8390e5f76c8be507136d4fd2387bea79cd64146b4b3dc1dc61ed75bf10b77d444cbd62cde02bfc582fcc1ca611551e2d5b4d1898c946b805c9c07495bd SHA512 c617c3b2ce6aa0293f8f18fabdc61dfa9bba0fd11bfe9a65685577a8a38487a02c7fcddf001d1e66ebf206563df0765f26fb3771283edd2da095d8846025ee36
+EBUILD Hyperbolica-1.0.14.ebuild 1326 BLAKE2B bce06e7706a28c9a5b416208a70ffb77aee2d585fe7039e1a76f2f038e29c19527bdd2c1c8005ce650d33076fc5ab48c04b5cd7676be5160077989034b187581 SHA512 b26a66e978f17f84a67b1f4ffb335797ed0212742b864df790f760eee3ca690f138548b044c05697256b31d603b9c66b2a05ae411e7848aea80cb991b56f8e2a
+MISC metadata.xml 247 BLAKE2B 789c80dabb34f534439182699e1b1cbd897fb88f38fcec2d5c233559e0af2799815164c764c72ba0d4adb8509e63083649c6941dc942359f751e07aeb6660409 SHA512 583b2aaac1bcc6d6ac34d7e990a5c13f82353313775748a4fd6efd9fbc55f3eb709139e78880fad914140e11e50de70eca80a0d1094cba81f7b88be0d4bb73ed
diff --git a/games-puzzle/Hyperbolica/metadata.xml b/games-puzzle/Hyperbolica/metadata.xml
new file mode 100644
index 0000000..4c4b24b
--- /dev/null
+++ b/games-puzzle/Hyperbolica/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>pmebuid@messagebox.email</email>
+<name>Philip Miess</name>
+</maintainer>
+</pkgmetadata>