summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-08-12 07:36:19 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-08-12 07:36:19 -0400
commit500c6710557107e6eeefe2bac36b52f34dec08b1 (patch)
tree782443be049ea37f63a982321d6ab84d09e761fd /dev-python/freecode-submit/freecode-submit-2.9.ebuild
parentfreecode-submit ebuild (diff)
downloadsuperposition-500c6710557107e6eeefe2bac36b52f34dec08b1.tar.gz
superposition-500c6710557107e6eeefe2bac36b52f34dec08b1.tar.bz2
superposition-500c6710557107e6eeefe2bac36b52f34dec08b1.zip
Install in prefix patch, fix shebang
Diffstat (limited to 'dev-python/freecode-submit/freecode-submit-2.9.ebuild')
-rw-r--r--dev-python/freecode-submit/freecode-submit-2.9.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/freecode-submit/freecode-submit-2.9.ebuild b/dev-python/freecode-submit/freecode-submit-2.9.ebuild
index 2043b5a..1d25073 100644
--- a/dev-python/freecode-submit/freecode-submit-2.9.ebuild
+++ b/dev-python/freecode-submit/freecode-submit-2.9.ebuild
@@ -5,8 +5,9 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="ssl(+)"
+DISTUTILS_SINGLE_IMPL=1
-inherit python-single-r1
+inherit distutils-r1
DESCRIPTION="Client for Freshcode and Freecode-like sites."
HOMEPAGE="http://www.catb.org/~esr/freecode-submit/"
@@ -19,3 +20,10 @@ IUSE=""
DEPEND="${PYTHON_DEPS}"
RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -i 's:PREFIX=:PREFIX?=:' Makefile || die 'Prefix fix sed failed.'
+ python_fix_shebang freecode-submit
+ distutils-r1_python_prepare_all
+}
+