summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/presage/files/presage-0.8.9-automagic.patch')
-rw-r--r--app-text/presage/files/presage-0.8.9-automagic.patch127
1 files changed, 127 insertions, 0 deletions
diff --git a/app-text/presage/files/presage-0.8.9-automagic.patch b/app-text/presage/files/presage-0.8.9-automagic.patch
new file mode 100644
index 0000000..ac7f503
--- /dev/null
+++ b/app-text/presage/files/presage-0.8.9-automagic.patch
@@ -0,0 +1,127 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -23,7 +23,7 @@
+
+
+ AC_INIT([presage],[0.8.9],[matteo.vescovi@yahoo.co.uk])
+-AM_INIT_AUTOMAKE([-Wall -Werror])
++AM_INIT_AUTOMAKE([-Wall])
+
+ AC_CONFIG_SRCDIR([src/lib/presage.cpp])
+ AC_CONFIG_HEADERS([config.h:config.hin])
+@@ -105,6 +105,13 @@
+ dnl ==================
+ dnl Checks for ncurses
+ dnl ==================
++AC_ARG_ENABLE([curses],
++ AS_HELP_STRING([--disable-curses],[disable curses support, needed for demo programs (default: enabled)]),
++ [enable_curses=$enableval],
++ [enable_curses=yes])
++
++if test "x$enable_curses" = "xyes"
++then
+ AC_CHECK_LIB([curses],
+ [initscr],
+ [have_curses_library=true],
+@@ -113,12 +120,19 @@
+ [have_curses_header=true],
+ [AC_MSG_WARN([curses header file not found. curses demo programs will not be built.])],
+ [])
+-AM_CONDITIONAL([HAVE_CURSES], [test "x$have_curses_library" = "xtrue" -a "x$have_curses_header" = "xtrue"])
++fi
++AM_CONDITIONAL([HAVE_CURSES], [test "x$have_curses_library" = "xtrue" -a "x$have_curses_header" = "xtrue" -a "x$enable_curses" = "xyes"])
+
+
+ dnl ==================
+ dnl Checks for tinyxml
+ dnl ==================
++AC_ARG_ENABLE([tinyxml],
++ AS_HELP_STRING([--disable-tinyxml],[disable tinyxml support (default: enabled)]),
++ [enable_tinyxml=$enableval],
++ [enable_tinyxml=yes])
++if test "x$enable_tinyxml" = "xtrue"
++then
+ AC_CHECK_LIB([tinyxml],
+ [main],
+ [have_tinyxml_library=true],
+@@ -127,6 +141,7 @@
+ [have_tinyxml_header=true],
+ [AC_MSG_WARN([tinyxml library not found. Embedded tinyxml library will be built.])],
+ [])
++fi
+ if test "x$have_tinyxml_library" != "xtrue" -o "x$have_tinyxml_header" != "xtrue"
+ then
+ build_tinyxml=yes
+@@ -134,7 +149,7 @@
+ build_tinyxml=no
+ AC_DEFINE([TIXML_USE_STL], [1], [Define to 1 to use STL string in TinyXML])
+ fi
+-AM_CONDITIONAL([BUILD_TINYXML], [test "x$build_tinyxml" = "xyes"])
++AM_CONDITIONAL([BUILD_TINYXML], [test "x$build_tinyxml" = "xyes" -a "x$enable_tinyxml" = "xyes"])
+
+
+ dnl =================
+@@ -203,10 +218,15 @@
+ dnl ==================
+ dnl Checks for CppUnit
+ dnl ==================
++AC_ARG_ENABLE([tests],
++ AS_HELP_STRING([--enable-tests],[enable tests (default: disabled)]),
++ [enable_tests=$enableval],
++ [enable_tests=no])
++
+ AM_PATH_CPPUNIT([1.9.6],
+ [],
+ [AC_MSG_WARN([CppUnit not found. Unit tests will not be built. CppUnit can be obtained from http://cppunit.sourceforge.net.])])
+-AM_CONDITIONAL([HAVE_CPPUNIT], [test "$CPPUNIT_LIBS"])
++AM_CONDITIONAL([HAVE_CPPUNIT], [test "$CPPUNIT_LIBS" -a "x$enable_tests" = "xyes"])
+
+
+ dnl ============================
+@@ -216,6 +236,7 @@
+ dnl ===============
+ dnl Checks for SWIG
+ dnl ===============
++
+ AC_PATH_PROG([SWIG], [swig])
+ if test ! "$SWIG"
+ then
+@@ -227,6 +248,11 @@
+ dnl =================
+ dnl Checks for Python
+ dnl =================
++AC_ARG_ENABLE([python],
++ AS_HELP_STRING([--disable-python],[disable python support, needed for python bindings (default: enabled)]),
++ [enable_python=$enableval],
++ [enable_python=yes])
++
+ AM_PATH_PYTHON([2.0],
+ [],
+ [AC_MSG_WARN([Python not found. Python is required to build presage python binding. Python can be obtained from http://www.python.org])])
+@@ -239,7 +264,7 @@
+ [AC_MSG_WARN([Python.h header file not found. Python development files are required to build presage python binding. Python can be obtained from http://www.python.org])],
+ [])
+ fi
+-AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != : -a "x$have_python_header" = "xtrue"])
++AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != : -a "x$have_python_header" = "xtrue" -a "x$enable_python" = "xyes"])
+
+
+ AC_ARG_ENABLE([python-binding],
+@@ -262,6 +288,7 @@
+ dnl ======================
+ dnl Checks for dbus python
+ dnl ======================
++
+ have_dbus_python=no
+ AC_MSG_CHECKING(for python dbus module)
+ $PYTHON -c "import dbus" 2&>/dev/null
+@@ -275,7 +299,7 @@
+ have_dbus_python=no
+ fi
+ AC_MSG_RESULT($have_dbus_python)
+fi
+-AM_CONDITIONAL([HAVE_DBUS_PYTHON], [test "x$have_dbus_python" = "xyes"])
++AM_CONDITIONAL([HAVE_DBUS_PYTHON], [test "x$have_dbus_python" = "xyes" -a "x$enable_python" = "xyes"])
+
+
+ dnl ========================