summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-07-04 20:28:35 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-07-04 20:28:35 -0400
commitce47dcb0254b16295ddd9db58658ae4c80e263b0 (patch)
tree10c299d702ef297ffc2421c7c034eefcf665edec
parentAdd zsdx and zsxd icons and menu icons... (diff)
downloadArmageddon-ce47dcb0254b16295ddd9db58658ae4c80e263b0.tar.gz
Armageddon-ce47dcb0254b16295ddd9db58658ae4c80e263b0.tar.bz2
Armageddon-ce47dcb0254b16295ddd9db58658ae4c80e263b0.zip
Fix Solarus packages, thanks to TomWij notes...
-rw-r--r--games-engines/solarus/solarus-1.0.4.ebuild12
-rw-r--r--games-engines/solarus/solarus-9999.ebuild15
-rw-r--r--games-rpg/zsdx/zsdx-1.6.2.ebuild10
-rw-r--r--games-rpg/zsdx/zsdx-9999.ebuild13
-rw-r--r--games-rpg/zsxd/zsxd-1.6.2.ebuild10
-rw-r--r--games-rpg/zsxd/zsxd-9999.ebuild13
6 files changed, 7 insertions, 66 deletions
diff --git a/games-engines/solarus/solarus-1.0.4.ebuild b/games-engines/solarus/solarus-1.0.4.ebuild
index 0142e1f..1ae1478 100644
--- a/games-engines/solarus/solarus-1.0.4.ebuild
+++ b/games-engines/solarus/solarus-1.0.4.ebuild
@@ -24,15 +24,3 @@ RDEPEND="
media-libs/sdl-image
media-libs/sdl-ttf"
DEPEND="${RDEPEND}"
-
-src_configure() {
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
-}
diff --git a/games-engines/solarus/solarus-9999.ebuild b/games-engines/solarus/solarus-9999.ebuild
index afc1eec..ab34b81 100644
--- a/games-engines/solarus/solarus-9999.ebuild
+++ b/games-engines/solarus/solarus-9999.ebuild
@@ -8,8 +8,7 @@ inherit games cmake-utils git-2
DESCRIPTION="An open-source Zelda-like 2D game engine"
HOMEPAGE="http://www.solarus-games.org/"
-EGIT_REPO_URI="git://github.com/christopho/${PN}.git
- https://github.com/christopho/${PN}.git"
+EGIT_REPO_URI="https://github.com/christopho/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
@@ -25,15 +24,3 @@ RDEPEND="
media-libs/sdl-image
media-libs/sdl-ttf"
DEPEND="${RDEPEND}"
-
-src_configure() {
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
-}
diff --git a/games-rpg/zsdx/zsdx-1.6.2.ebuild b/games-rpg/zsdx/zsdx-1.6.2.ebuild
index 7ef37bd..4becefb 100644
--- a/games-rpg/zsdx/zsdx-1.6.2.ebuild
+++ b/games-rpg/zsdx/zsdx-1.6.2.ebuild
@@ -18,15 +18,7 @@ IUSE=""
RDEPEND="=games-engines/solarus-1.0.4"
DEPEND="${RDEPEND}"
-src_configure() {
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
src_install() {
- cmake-utils_src_install
+ default
make_desktop_entry ${PN} "Zelda: Mystery of Solarus DX"
}
diff --git a/games-rpg/zsdx/zsdx-9999.ebuild b/games-rpg/zsdx/zsdx-9999.ebuild
index 53f46e1..ad9de87 100644
--- a/games-rpg/zsdx/zsdx-9999.ebuild
+++ b/games-rpg/zsdx/zsdx-9999.ebuild
@@ -8,8 +8,7 @@ inherit games cmake-utils git-2
DESCRIPTION="A free 2D Zelda fangame"
HOMEPAGE="http://www.solarus-games.org/"
-EGIT_REPO_URI="git://github.com/christopho/${PN}.git
- https://github.com/christopho/${PN}.git"
+EGIT_REPO_URI="https://github.com/christopho/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
@@ -19,16 +18,8 @@ IUSE=""
RDEPEND="=games-engines/solarus-9999"
DEPEND="${RDEPEND}"
-src_configure() {
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
src_install() {
- cmake-utils_src_install
+ default
newicon -s 48 build/icons/${PN}_icon_48.png ${PN}.png
make_desktop_entry ${PN} "Zelda: Mystery of Solarus DX" ${PN}.png
}
diff --git a/games-rpg/zsxd/zsxd-1.6.2.ebuild b/games-rpg/zsxd/zsxd-1.6.2.ebuild
index 35f0efa..2b8c5d0 100644
--- a/games-rpg/zsxd/zsxd-1.6.2.ebuild
+++ b/games-rpg/zsxd/zsxd-1.6.2.ebuild
@@ -18,15 +18,7 @@ IUSE=""
RDEPEND="=games-engines/solarus-1.0.4"
DEPEND="${RDEPEND}"
-src_configure() {
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
src_install() {
- cmake-utils_src_install
+ default
make_desktop_entry ${PN} "Zelda: Mystery of Solarus XD"
}
diff --git a/games-rpg/zsxd/zsxd-9999.ebuild b/games-rpg/zsxd/zsxd-9999.ebuild
index ff0927f..645dd59 100644
--- a/games-rpg/zsxd/zsxd-9999.ebuild
+++ b/games-rpg/zsxd/zsxd-9999.ebuild
@@ -8,8 +8,7 @@ inherit games cmake-utils git-2
DESCRIPTION="A free 2D Zelda fangame parody"
HOMEPAGE="http://www.solarus-games.org/"
-EGIT_REPO_URI="git://github.com/christopho/${PN}.git
- https://github.com/christopho/${PN}.git"
+EGIT_REPO_URI="https://github.com/christopho/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
@@ -19,16 +18,8 @@ IUSE=""
RDEPEND="=games-engines/solarus-9999"
DEPEND="${RDEPEND}"
-src_configure() {
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
src_install() {
- cmake-utils_src_install
+ default
newicon -s 48 build/icons/${PN}_icon_48.png ${PN}.png
make_desktop_entry ${PN} "Zelda: Mystery of Solarus XD" ${PN}.png
}