summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-05-30 21:25:41 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-05-30 21:25:41 -0400
commit4a221b4144ec96ea9999eb1294a048783a79268c (patch)
treea34bd6cd1949758eb657be3509d2654e81c3813c /app-editors
parentGit version of vim-qt ebuild draft added to the tree. (diff)
downloadArmageddon-4a221b4144ec96ea9999eb1294a048783a79268c.tar.gz
Armageddon-4a221b4144ec96ea9999eb1294a048783a79268c.tar.bz2
Armageddon-4a221b4144ec96ea9999eb1294a048783a79268c.zip
Fixed ebuild format.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-qt/Manifest2
-rw-r--r--app-editors/vim-qt/vim-qt-9999.ebuild36
2 files changed, 19 insertions, 19 deletions
diff --git a/app-editors/vim-qt/Manifest b/app-editors/vim-qt/Manifest
index 890a69d..abeee41 100644
--- a/app-editors/vim-qt/Manifest
+++ b/app-editors/vim-qt/Manifest
@@ -1 +1 @@
-EBUILD vim-qt-9999.ebuild 1690 RMD160 d3cd7330197a325a1c24ed0a8a2eea627b2833d0 SHA1 253bb06f2ef50f248f32edaa91715aeafd9bb620 SHA256 c5bdb480b27a6a91fdcedf108a49b5ebcd62e9f2b6677db04e80ee733cb9c610
+EBUILD vim-qt-9999.ebuild 1595 RMD160 ebcad5329cdeca3e169482f4bb7a03d1533118be SHA1 1ce7bfe8b4bb5efb7b0ef1922971e62b97621617 SHA256 49002a12421f9a45d119879b4b0cb800744640ae9ce537fd7931981ce5d78fad
diff --git a/app-editors/vim-qt/vim-qt-9999.ebuild b/app-editors/vim-qt/vim-qt-9999.ebuild
index 56e5b6f..c4a5291 100644
--- a/app-editors/vim-qt/vim-qt-9999.ebuild
+++ b/app-editors/vim-qt/vim-qt-9999.ebuild
@@ -20,40 +20,40 @@ DEPEND="
>=app-admin/eselect-vi-1.1
>=sys-apps/sed-4
sys-devel/autoconf
- >=sys-libs/ncurses-5.2-r2
+ >=sys-libs/ncurses-5.2-r2
gpm? ( >=sys-libs/gpm-1.19.3 )
nls? ( virtual/libintl )
cscope? ( dev-util/cscope )
perl? ( dev-lang/perl )
acl? ( kernel_linux? ( sys-apps/acl ) )
ruby? ( =dev-lang/ruby-1.8* )
- !<app-vim/align-30-r1
- !<app-vim/vimbuddy-0.9.1-r1
- !<app-vim/autoalign-11
- !<app-vim/supertab-0.41
+ !<app-vim/align-30-r1
+ !<app-vim/vimbuddy-0.9.1-r1
+ !<app-vim/autoalign-11
+ !<app-vim/supertab-0.41
>=x11-libs/qt-core-4.7.0:4
>=x11-libs/qt-gui-4.7.0:4"
RDEPEND="${DEPEND}"
src_configure() {
local myconf
-
+
use debug && append-flags "-DDEBUG"
-
+
myconf="--with-features=huge \
--enable-multibyte"
- myconf="${myconf} `use_enable gpm`"
- myconf="${myconf} `use_enable perl perlinterp`"
- myconf="${myconf} `use_enable python pythoninterp`"
- myconf="${myconf} `use_enable ruby rubyinterp`"
- myconf="${myconf} `use_enable nls`"
- myconf="${myconf} `use_enable acl`"
- myconf="${myconf} --enable-gui=qt --with-vim-name=qvim --with-x"
-
+ myconf+="$(use_enable gpm)"
+ myconf+="$(use_enable perl perlinterp)"
+ myconf+="$(use_enable python pythoninterp)"
+ myconf+="$(use_enable ruby rubyinterp)"
+ myconf+="$(use_enable nls)"
+ myconf+="$(use_enable acl)"
+ myconf+="--enable-gui=qt --with-vim-name=qvim --with-x"
+
if ! use cscope ; then
- sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || \
- die "couldn't disable cscope"
- fi
+ sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || \
+ die "couldn't disable cscope"
+ fi
econf ${myconf} || die "vim-qt configure failed"
}