aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAstroFloyd <AstroFloyd@gmail.com>2021-12-18 10:34:15 +0100
committerAstroFloyd <AstroFloyd@gmail.com>2021-12-18 10:34:15 +0100
commit9cbe987f6bd282ddee7e6c3862b36e79108b5262 (patch)
tree1c3ec23c0af48f33cfe5f32c4bb9611712c09247
parentsci-libs/gds-frameio: initial ebuild for v2.19.5. (diff)
downloadAstroFloyd-9cbe987f6bd282ddee7e6c3862b36e79108b5262.tar.gz
AstroFloyd-9cbe987f6bd282ddee7e6c3862b36e79108b5262.tar.bz2
AstroFloyd-9cbe987f6bd282ddee7e6c3862b36e79108b5262.zip
sci-libs/gds-dmt: initial ebuild for v2.19.0.
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: AstroFloyd <AstroFloyd@gmail.com>
-rw-r--r--sci-libs/gds-dmt/ChangeLog6
-rw-r--r--sci-libs/gds-dmt/Manifest4
-rw-r--r--sci-libs/gds-dmt/gds-dmt-2.19.0.ebuild43
-rw-r--r--sci-libs/gds-dmt/metadata.xml20
4 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/gds-dmt/ChangeLog b/sci-libs/gds-dmt/ChangeLog
new file mode 100644
index 0000000..3a96179
--- /dev/null
+++ b/sci-libs/gds-dmt/ChangeLog
@@ -0,0 +1,6 @@
+*gds-dmt-2.19.0 (18 Dec 2021)
+
+ 18 Dec 2021; AstroFloyd <AstroFloyd@gmail.com> +gds-dmt-2.19.0.ebuild,
+ +metadata.xml:
+ sci-libs/gds-dmt: initial ebuild for v2.19.0.
+
diff --git a/sci-libs/gds-dmt/Manifest b/sci-libs/gds-dmt/Manifest
new file mode 100644
index 0000000..ddbf56f
--- /dev/null
+++ b/sci-libs/gds-dmt/Manifest
@@ -0,0 +1,4 @@
+DIST gds-dmt-2.19.0.tar.gz 678496 BLAKE2B fdfa977e5a928ba72b0ecb46e75e84bc3ecf79cdd3c8f30725f463945c249a6ab7dd5498cb0a6717cb5b3489ae935e9bfedb2209e537a66466a7dca6373de1e9 SHA512 70c066f708bc0b6be26a2f1d7d397a9ea9f8c49191c077be14fffa1b5e0fa71ac79a627d178fb45777e44b1e211073f663e23afe420e69e4b0a4dc9466424e51
+EBUILD gds-dmt-2.19.0.ebuild 1066 BLAKE2B a81d06e5cb4aa8f0378bc0b8d21d9ec7618d439d92709522ce3534039f74573d4db06a36a5fc22b58e09b3c240ba1e7aa88af048edcc8c242dbe406e96902a37 SHA512 919c8cab1662306ccf16aef2ff353facf039810a02f1b8049993207f57b76adbf295abcc8ff7917fa7445269a49e6fde9a526f5a198a989ffd4efd54a13835e4
+MISC ChangeLog 170 BLAKE2B ac98d5804a05d8a610bc5c61e9f8ed6dca377cc884043028415bfa768547840d4c1349943117e49827ce902fee8549782501cc4c05cb21535712bba35d6cc0ff SHA512 d2b033b1b7f7a62861f076a2f28f1235882d651142e92d97fd6e201282b2b0897a95aec0580aedb0eff27ad25538d1d02e9afba6056662e75005a1d9c29ee308
+MISC metadata.xml 828 BLAKE2B 301aecd477312963e6eb2580d7d6e9a58fa5ccd1c88999ed3a2a8e855083acf98105591dec8445ec04304356da953ea3c537d52e6e51ba6a4c4e232130ef398a SHA512 12e179e2bc63f8fdbcc527abce8d5ab1fe2e037496e425e3cd2f46b37d9e50038f6bc9ed38a57f134fbfbc7ef63452804651e4172c5ea9778890123d8be6bcc1
diff --git a/sci-libs/gds-dmt/gds-dmt-2.19.0.ebuild b/sci-libs/gds-dmt/gds-dmt-2.19.0.ebuild
new file mode 100644
index 0000000..b135df9
--- /dev/null
+++ b/sci-libs/gds-dmt/gds-dmt-2.19.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="LIGO Global Diagnostic System"
+HOMEPAGE="http://software.ligo.org/lscsoft"
+SRC_URI="http://software.ligo.org/lscsoft/source/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fast-install -largefile -libtool-lock monitors omega online root-objects static-libs"
+# offline
+
+RDEPEND="dev-libs/expat
+ dev-libs/openssl
+ sci-libs/fftw
+ sci-libs/gds-frameio
+ sci-libs/gds-lsmp
+ sci-libs/gds
+ sci-libs/ldas-tools-al
+ sci-libs/ldas-tools-framecpp
+ sci-libs/metaio
+ sci-physics/root:*
+ sys-libs/zlib
+"
+DEPEND=${RDEPEND}
+
+src_configure() {
+ econf \
+ $(use_enable fast-install) \
+ $(use_enable largefile) \
+ $(use_enable libtool-lock) \
+ $(use_enable monitors) \
+ $(use_enable omega) \
+ $(use_enable online) \
+ $(use_enable root-objects) \
+ $(use_enable static-libs static) \
+ --includedir=/usr/include/gds
+ # Header files are expected to sit in /usr/include/gds
+}
+# $(use_enable offline) \
diff --git a/sci-libs/gds-dmt/metadata.xml b/sci-libs/gds-dmt/metadata.xml
new file mode 100644
index 0000000..6a28027
--- /dev/null
+++ b/sci-libs/gds-dmt/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>AstroFloyd@gmail.com</email>
+ <name>AstroFloyd</name>
+ </maintainer>
+ <use>
+ <flag name='fast-install'>Optimize for fast installation</flag>
+ <flag name='largefile'>Omit support for large files</flag>
+ <flag name='libtool-lock'>Avoid locking (might break parallel builds)</flag>
+ <flag name='monitors'>Build all monitors</flag>
+ <flag name='omega'>Build Omega_c only</flag>
+ <flag name='online'>Online program version</flag>
+ <flag name='root-objects'>Build root dictionary in shared objects</flag>
+ <!--
+ <flag name='offline'>Offline program version</flag> Not currently supported (2021-12-15)
+ -->
+ </use>
+</pkgmetadata>