aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAstroFloyd <AstroFloyd@gmail.com>2017-09-17 17:05:28 +0200
committerAstroFloyd <AstroFloyd@gmail.com>2017-09-17 17:05:28 +0200
commit66764cd81b27dfa437d53e59f0c970a000393c6b (patch)
treeb3663331d4b1c665f22d9f0c26d3b3fc202664fa /sys-kernel/gentoo-sources/gentoo-sources-4.12.5.ebuild
parentsci-astronomy/soltrack: version bump to v2.2 (diff)
downloadAstroFloyd-66764cd81b27dfa437d53e59f0c970a000393c6b.tar.gz
AstroFloyd-66764cd81b27dfa437d53e59f0c970a000393c6b.tar.bz2
AstroFloyd-66764cd81b27dfa437d53e59f0c970a000393c6b.zip
sys-kernel/gentoo-sources: version bump to v4.12.5
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.12.5.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.12.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.12.5.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.12.5.ebuild
new file mode 100644
index 0000000..b38bd27
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.12.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="6"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}