aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAstroFloyd <AstroFloyd@gmail.com>2013-10-19 10:20:44 +0200
committerAstroFloyd <AstroFloyd@gmail.com>2013-10-19 10:20:44 +0200
commita0556866437ac6917615c68e98eba50047cdd774 (patch)
treee991c00c5cb0e0251083b55855bedc943fb39f9a /sys-kernel
parentapp-office/libreoffice-bin: added files/ (diff)
downloadAstroFloyd-a0556866437ac6917615c68e98eba50047cdd774.tar.gz
AstroFloyd-a0556866437ac6917615c68e98eba50047cdd774.tar.bz2
AstroFloyd-a0556866437ac6917615c68e98eba50047cdd774.zip
Version bump local copy of gentoo-sources
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog10
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.10.7-r1.ebuild39
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index 19cb03a..f5b2dd5 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -2,6 +2,16 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 19 Oct 2013; AstroFloyd <AstroFloyd@gmail.com>
+ +gentoo-sources-3.10.7-r1.ebuild:
+ Version bump local copy of gentoo-sources
+
+*gentoo-sources-3.10.7-r1 (19 Oct 2013)
+
+ 19 Oct 2013; AstroFloyd <AstroFloyd@gmail.com>
+ +gentoo-sources-3.10.7-r1.ebuild:
+ Version bump local copy of gentoo-sources
+
*gentoo-sources-3.10.7 (18 Sep 2013)
18 Sep 2013; AstroFloyd <AstroFloyd@gmail.com>
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.10.7-r1.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.10.7-r1.ebuild
new file mode 100644
index 0000000..e6cdb90
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.10.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.10.7-r1.ebuild,v 1.1 2013/09/25 17:40:46 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_GENPATCHES_VER="1"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+
+GENPATCH_PREFIX="genpatches-${PV}-${K_GENPATCHES_VER}"
+
+SRC_URI="
+ ${KERNEL_URI}
+ mirror://gentoo/${GENPATCH_PREFIX}.base.tar.xz
+ mirror://gentoo/${GENPATCH_PREFIX}.extras.tar.xz
+ ${ARCH_URI}"
+
+UNIPATCH_LIST="
+ ${GENPATCH_PREFIX}.base.tar.xz
+ ${GENPATCH_PREFIX}.extras.tar.xz"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}