aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/showem/showem-1.0.4.ebuild')
-rw-r--r--app-portage/showem/showem-1.0.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/showem/showem-1.0.4.ebuild b/app-portage/showem/showem-1.0.4.ebuild
new file mode 100644
index 0000000..3a55a0f
--- /dev/null
+++ b/app-portage/showem/showem-1.0.4.ebuild
@@ -0,0 +1,32 @@
+# ebuild for showem (a simple emerge progress viewer)
+# Copyright (c) 2015 sakaki <sakaki@deciban.com>
+# (c) 2021 quarkyalice <quarkyalice@disroot.org>
+# License: GPL v2
+# NO WARRANTY
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="View output of a parallel emerge from a separate terminal"
+BASE_SERVER_URI="https://github.com/alicela1n"
+HOMEPAGE="${BASE_SERVER_URI}/${PN}"
+SRC_URI="${BASE_SERVER_URI}/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm ~ppc"
+
+RESTRICT="mirror"
+
+S=${WORKDIR}/${PN}-${PV}
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=sys-libs/ncurses-5.9-r2
+ >=app-shells/bash-4.2"
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+}