summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/fakechroot/fakechroot-2.16.ebuild')
-rw-r--r--sys-apps/fakechroot/fakechroot-2.16.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/fakechroot/fakechroot-2.16.ebuild b/sys-apps/fakechroot/fakechroot-2.16.ebuild
new file mode 100644
index 0000000..ddc8160
--- /dev/null
+++ b/sys-apps/fakechroot/fakechroot-2.16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Provide a faked chroot environment without requiring root privileges"
+HOMEPAGE="http://fakechroot.alioth.debian.org/"
+SRC_URI="mirror://debian/pool/main/f/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.14-fix_chk_fail.patch
+ sed -i -e "s/-g//" src/Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS README THANKS
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}