summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kriegner <dominik.kriegner@gmail.com>2018-09-30 23:20:13 +0200
committerDominik Kriegner <dominik.kriegner@gmail.com>2018-09-30 23:20:13 +0200
commitbc1ab70e5a23727dea7ffe4f638344d02d076e25 (patch)
treeca5a0d16db25da8b9b52db7de3c5052158cc9548
parentrepoman fixes (whitespace issues) (diff)
downloadanaximander-bc1ab70e5a23727dea7ffe4f638344d02d076e25.tar.gz
anaximander-bc1ab70e5a23727dea7ffe4f638344d02d076e25.tar.bz2
anaximander-bc1ab70e5a23727dea7ffe4f638344d02d076e25.zip
dev-libs/wlroots: new ebuild; work in progress
-rw-r--r--dev-libs/wlroots/Manifest2
-rw-r--r--dev-libs/wlroots/metadata.xml18
-rw-r--r--dev-libs/wlroots/wlroots-9999.ebuild60
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/wlroots/Manifest b/dev-libs/wlroots/Manifest
new file mode 100644
index 0000000..b9cc270
--- /dev/null
+++ b/dev-libs/wlroots/Manifest
@@ -0,0 +1,2 @@
+EBUILD wlroots-9999.ebuild 1599 BLAKE2B 4dcda893ae3045180f12346745fe28d884ee90657ac7034e45cf25c583f79a77ccbb42b492c07a1fe34c97d978cda6f29a4a538ad47074f3ab3705d325e6a3bc SHA512 4eece445cb9b6212489efd42e7b57fb52cee2b84075a7de599916659088625217ca118337b8bdc451467aba5f362846c51108096123fa4c992491360236aea32
+MISC metadata.xml 686 BLAKE2B 75f1311c9946db54a4be7f869b0af221c7a439c9a859d8245732a3062f87d998f59ac88188801730d2f611c87da24922fb5aa7be1e13dd3c31abff9d389a4629 SHA512 8209c07d3f7b19b394d983415df0704bf1003cc6a0ffc65a3fcd3e638d93670f53a8b740177f7378645eb631d4f91af41a96ddb14cc8e07d3cc8934010b82295
diff --git a/dev-libs/wlroots/metadata.xml b/dev-libs/wlroots/metadata.xml
new file mode 100644
index 0000000..3804e9c
--- /dev/null
+++ b/dev-libs/wlroots/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>dominik.kriegner@gmail.com</email>
+<name>Dominik Kriegner</name>
+</maintainer>
+<longdescription lang="en">
+The wlroots project provides a modular basis for Sway and other Wayland compositors
+</longdescription>
+<use>
+<flag name="elogind">Enable elogind support to get user session</flag>
+<flag name="systemd">Enable support for systemd-logind</flag>
+<flag name="xwayland">Enable XWayland application support</flag>
+<flag name="x11">Enable X11 backend</flag>
+<flag name="xkb">Use xcb-xkb util library</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-libs/wlroots/wlroots-9999.ebuild b/dev-libs/wlroots/wlroots-9999.ebuild
new file mode 100644
index 0000000..6afdc4b
--- /dev/null
+++ b/dev-libs/wlroots/wlroots-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson git-r3
+
+DESCRIPTION="A modular Wayland compositor library"
+HOMEPAGE="https://swaywm.org"
+
+EGIT_REPO_URI="https://github.com/swaywm/wlroots.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+# 1) currently the build system seems not to support disabling xkb
+# 2) examples require most likely ffmpeg above 4.0 and are therefore currently not
+# built
+IUSE="caps +systemd -elogind x11 +xwayland +xkb examples"
+REQUIRED_USE="?? ( systemd elogind )"
+
+DEPEND=">=dev-libs/wayland-1.15.0
+ >=dev-libs/wayland-protocols-1.15.0
+ >=media-libs/mesa-17.1.0[egl,gles2,gbm]
+ x11-libs/libdrm
+ >=dev-libs/libinput-1.7.0
+ xkb? ( x11-libs/libxkbcommon )
+ virtual/udev
+ x11-libs/pixman
+ caps? ( sys-libs/libcap )
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+ x11? ( x11-libs/libxcb
+ x11-libs/xcb-util-wm )
+ examples? ( media-libs/libpng:0/16
+ media-video/ffmpeg )
+ xwayland? ( x11-libs/libxcb
+ x11-libs/xcb-util-wm )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ if use systemd || use elogind ; then
+ local uselogind="enabled"
+ else
+ local uselogind="disabled"
+ fi
+ local emesonargs=(
+ -Dlibcap=$(usex caps enabled disabled)
+ -Dlogind=$uselogind
+ -Dlogind-provider=$(usex elogind elogind systemd)
+ -Dx11-backend=$(usex x11 enabled disabled)
+ -Dxcb-icccm=$(usex x11 enabled disabled)
+ -Dxcb-xkb=$(usex xkb enabled disabled)
+ -Dxwayland=$(usex xwayland enabled disabled)
+ $(meson_use examples)
+ $(meson_use examples rootston)
+ )
+ meson_src_configure
+}