summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Klopfenstein <benklop@gmail.com>2015-08-05 02:10:15 -0600
committerBen Klopfenstein <benklop@gmail.com>2015-08-05 02:10:15 -0600
commit5aa1e5fceac451ee629ab0b5a81e0847bf9d9683 (patch)
tree83466ad601abf5c89867559a1aa483c24d2434f2 /x11-misc
downloadbenklop-5aa1e5fceac451ee629ab0b5a81e0847bf9d9683.tar.gz
benklop-5aa1e5fceac451ee629ab0b5a81e0847bf9d9683.tar.bz2
benklop-5aa1e5fceac451ee629ab0b5a81e0847bf9d9683.zip
Initial commit
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/hhpc/Manifest1
-rw-r--r--x11-misc/hhpc/hhpc-0.3.1.ebuild32
-rw-r--r--x11-misc/nodm/Manifest6
-rw-r--r--x11-misc/nodm/files/nodm.confd23
-rw-r--r--x11-misc/nodm/files/nodm.initd22
-rw-r--r--x11-misc/nodm/files/nodm.service16
-rw-r--r--x11-misc/nodm/files/xdm.patch18
-rw-r--r--x11-misc/nodm/nodm-0.11-r2.ebuild52
8 files changed, 170 insertions, 0 deletions
diff --git a/x11-misc/hhpc/Manifest b/x11-misc/hhpc/Manifest
new file mode 100644
index 0000000..a94d7a3
--- /dev/null
+++ b/x11-misc/hhpc/Manifest
@@ -0,0 +1 @@
+EBUILD hhpc-0.3.1.ebuild 586 SHA256 cb967bb6c18ba30b265f78b0ce5872082c92dfc447e9585189752148ae0f4d8c SHA512 d5cc50bfe4ea17827dafd56a74f51e443f1375f29f0b65fddf3964deb278762898b7a10aa4922b0a7d6f86ce1ce8f9b3d491c6260905cb4bcd1533b769a68838 WHIRLPOOL 3d82218e650ba866d4bc145eeda6c4c4e9a771be0c99adb9697515d29c76b6719ca92b17aa942a83d91a7baa9918c3269be793d084131922e11479a4eec7e636
diff --git a/x11-misc/hhpc/hhpc-0.3.1.ebuild b/x11-misc/hhpc/hhpc-0.3.1.ebuild
new file mode 100644
index 0000000..5aa7048
--- /dev/null
+++ b/x11-misc/hhpc/hhpc-0.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit git-r3
+
+DESCRIPTION="hhpc is a lightweight alternative to unclutter. it is essentially hpc written in C."
+HOMEPAGE="https://github.com/aktau/hhpc/"
+SRC_URI=""
+
+EGIT_REPO_URI="https://github.com/aktau/hhpc"
+EGIT_BRANCH="master"
+EGIT_TAG="v0.3.1"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake
+}
+
+src_install()
+{
+ insinto /usr/bin
+ dobin hhpc || die "Install failed!"
+}
+
diff --git a/x11-misc/nodm/Manifest b/x11-misc/nodm/Manifest
new file mode 100644
index 0000000..8bb6994
--- /dev/null
+++ b/x11-misc/nodm/Manifest
@@ -0,0 +1,6 @@
+AUX nodm.confd 592 SHA256 d1946f982eadb74c3b7cd978d4690186433fc3d6462f92d6ad28a55aa41fab2b SHA512 af1ca8b770761b2482b500278501143444af2ed505fd31283d178e154ab6a079cbac701cb59d7e04bcb785fd79413f775d919797399fefd2dfd309626bff1907 WHIRLPOOL 72a2991dcdd3a8bf6aaf765d435fa2a9fc6dc81f19ec74ce1e2638a0b60852ec681e5c34898cd0a9727bf43e0205b36d5def66b65812a68bbb401682746042a2
+AUX nodm.initd 423 SHA256 06e894d8388890007d9ae4e9530d3f8d4db65b2a61b7ecbc6e584bab2633f689 SHA512 3fcdd57975aa8537d2d6085ed11f1cfe1e149522ee07bff12d5e94b9d31be748177bf2fd85b9e0b1840ee011cb69e2be11921f22b4f7fb5173dc9f6ca130b16a WHIRLPOOL a7565a30212d322759409cb4c00bbcb9689a6a4af51381043b7211821be17cad4165ab6440d85bdb8026f8b6bc491c0328c3c3f33ef5af7ff87a540cdd669d5b
+AUX nodm.service 305 SHA256 c8df5173cd8d237184afc669528017271bcec48c6cac851f78800e202bfd0eba SHA512 fba31fde575d52eda6ee0ea78d0e0617015fdc7c9ad9561a55de531902c7a47f496b830799e6932247f15c80a1b7ab41b048d185ce22fe2bbdae4855df17a8a3 WHIRLPOOL ec56b0546464c9101a511582d722618c04ee63ef73cbde47c856e2ff72710c48611ab2308e2ce5fa43d5c92c4676c8dea3e5bd99ccc4d3c40f3f75b0b47fe85e
+AUX xdm.patch 549 SHA256 bfe98a23fe46250170f2b9c8e6dace4ac27ac3c24b2429f4a5404ad562a5f6a3 SHA512 728443ff1b59971b8938d78c62d34489820a0cccc59a5c40541f5f293fcd64c26cace60b6c3e07743242f7c43c85fc03945b91f6b07c215b30fb33852f2f59b2 WHIRLPOOL dc878c1a69f56de25bfa3a31890b5e29c7254dff8b627be829b27c394489c75706a564c17530747f5efa5f9852fe43fd19d8459948017616f7bb924390368f42
+DIST nodm_0.11.orig.tar.gz 119074 SHA256 f9ec63d4a8e71f1948af3daa82394b441d34449933329345975afa6b6562c9a6 SHA512 1525b58eca1e6fd498d1be5eb6c340a13f82d7a0b5b42bbd930bad7f4389f3d244d9f7db9a655d861d578d03cc55ca1acf9ca54a1871bf82afc4310d370dba4c WHIRLPOOL 122f43178c92197b3389bfa3ac9d8456af500e85cc9f916e2fa43ae50e23420a9e602bfdcdde0f496426cc5778752f71a0328baa284eac1d97d14d988a1b5f3e
+EBUILD nodm-0.11-r2.ebuild 1392 SHA256 44b045847952b9ebd153153a10fdcb20d21a494bae4e380ae242a32aa52a0b30 SHA512 b2115007bd1ea8033104c97fee4e38f92e59402a6fc21e5854636a003473d6446cdc7887ce99c85758d1f0a0e97817800fcc1ae14b7dae235e435d1e0d5138e3 WHIRLPOOL 0f5547c92c1270dba26eeb19b1666e65d548de217809ee65d82dd72034449eb7c69a894a83efa220903d65387e069411f0a1d6110ec16255f034dbc0026c7b94
diff --git a/x11-misc/nodm/files/nodm.confd b/x11-misc/nodm/files/nodm.confd
new file mode 100644
index 0000000..23a08e0
--- /dev/null
+++ b/x11-misc/nodm/files/nodm.confd
@@ -0,0 +1,23 @@
+# /etc/conf.d/nodm: config file for /etc/init.d/nodm
+
+# See the nodm(8) manpage for more info.
+
+# The user to automatically login.
+NODM_USER=""
+
+# The VT the X server should run on.
+NODM_FIRST_VT="7"
+
+# The options to pass to the X server.
+NODM_X_OPTIONS="-nolisten tcp -br -novtswitch -quiet"
+
+# The minimum time (in seconds) that a session should
+# last to be considered successful. nodm will restart
+# the session if it lasts less than this time.
+NODM_MIN_SESSION_TIME="60"
+
+# The X session to start.
+NODM_XSESSION="/etc/X11/Sessions/Xsession"
+
+# The options to pass to nodm.
+NODM_OPTS=""
diff --git a/x11-misc/nodm/files/nodm.initd b/x11-misc/nodm/files/nodm.initd
new file mode 100644
index 0000000..2d49116
--- /dev/null
+++ b/x11-misc/nodm/files/nodm.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+
+depend() {
+ need local
+}
+
+start() {
+ export NODM_USER NODM_FIRST_VT NODM_X_OPTIONS \
+ NODM_MIN_SESSION_TIME NODM_XSESSION
+
+ ebegin "Starting nodm"
+ start-stop-daemon --start --quiet --background --make-pidfile \
+ --pidfile /var/run/nodm.pid --exec /usr/sbin/nodm \
+ -- ${NODM_OPTS}
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping nodm"
+ start-stop-daemon --stop --quiet --pidfile /var/run/nodm.pid
+ eend $?
+}
diff --git a/x11-misc/nodm/files/nodm.service b/x11-misc/nodm/files/nodm.service
new file mode 100644
index 0000000..5584c85
--- /dev/null
+++ b/x11-misc/nodm/files/nodm.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=NoDM Display Manager
+After=network.target
+
+[Service]
+Type=simple
+User=root
+Group=root
+EnvironmentFile=/etc/conf.d/nodm
+ExecStart=/bin/sh -c "export NODM_USER NODM_FIRST_VT NODM_X_OPTIONS NODM_MIN_SESSION_TIME NODM_XSESSION; /usr/sbin/nodm -- ${NODM_OPTS}"
+
+# Give a reasonable amount of time for the server to start up/shut down
+TimeoutSec=300
+
+[Install]
+WantedBy=multi-user.target
diff --git a/x11-misc/nodm/files/xdm.patch b/x11-misc/nodm/files/xdm.patch
new file mode 100644
index 0000000..5ac41b9
--- /dev/null
+++ b/x11-misc/nodm/files/xdm.patch
@@ -0,0 +1,18 @@
+--- /etc/init.d/xdm.orig 2011-12-21 11:50:37.000000000 +1100
++++ /etc/init.d/xdm 2012-04-12 16:28:41.058098417 +1000
+@@ -101,6 +101,15 @@
+ PIDFILE=/var/run/lightdm.pid
+ START_STOP_ARGS="--background"
+ ;;
++ nodm)
++ EXE=/usr/sbin/nodm
++ PIDFILE=/var/run/nodm.pid
++ START_STOP_ARGS="--background --make-pidfile"
++
++ source /etc/nodm.conf
++ export NODM_USER NODM_FIRST_VT NODM_X_OPTIONS \
++ NODM_MIN_SESSION_TIME NODM_XSESSION
++ ;;
+ *)
+ # first find out if there is such executable
+ EXE="$(which ${MY_XDM} 2>/dev/null)"
diff --git a/x11-misc/nodm/nodm-0.11-r2.ebuild b/x11-misc/nodm/nodm-0.11-r2.ebuild
new file mode 100644
index 0000000..d1d3b6c
--- /dev/null
+++ b/x11-misc/nodm/nodm-0.11-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit pam
+inherit systemd
+
+DESCRIPTION="nodm is an automatic display manager which automatically starts an X session at system boot"
+HOMEPAGE="http://www.enricozini.org/sw/nodm/"
+#SRC_URI="http://www.enricozini.org/sw/${PN}/${P}.tar.gz"
+SRC_URI="https://launchpad.net/debian/+archive/primary/+files/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+DEPEND="virtual/pam x11-base/xorg-server"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's:-Werror::' Makefile.in || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ newinitd "${FILESDIR}/nodm.initd" nodm || die
+ newconfd "${FILESDIR}/nodm.confd" nodm || die
+
+ if use systemd ; then
+ #install systemd service
+ systemd_dounit "${FILESDIR}/nodm.service" || die
+ fi
+
+ pamd_mimic system-local-login nodm auth account password session
+}
+
+pkg_postinst() {
+ elog "If you're using fbsplash to display a splash screen during boot,"
+ elog "then you need to have the following set in '/etc/conf.d/splash'."
+ elog
+ elog "SPLASH_XSERVICE=\"nodm\""
+ elog
+ elog "If you don't, you will most likely end up at tty1 at the end of"
+ elog "the boot process (instead of in an X session)."
+}