summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pport')
-rw-r--r--app-misc/pport/Manifest2
-rw-r--r--app-misc/pport/pport-0.6.9.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/pport/Manifest b/app-misc/pport/Manifest
new file mode 100644
index 0000000..6cf2801
--- /dev/null
+++ b/app-misc/pport/Manifest
@@ -0,0 +1,2 @@
+DIST pport-0.6.9.tar.gz 214567 SHA256 697b1cdbc2b77f6eba0f55ddf2f76d246c4b599dcca2d35fe2664a32bbf4a9ca SHA512 762530f80e8f22bba018c6f157c55cb8062ac7694a343a3fb64dca8ac9f58afb237c434ee58245915544c84bcb3c1de7187cc02eadc8ae43b872a395ac260a00 WHIRLPOOL 41b935c4298a058f2bd8588b084796453c310b260fd6b2050b36d6482694da1e0b6041c2c6ac838c40f94fdfadb2361b1bd194c520d628f4d5f6ceca5e2c2447
+EBUILD pport-0.6.9.ebuild 653 SHA256 d66f2a6ba2c587ccb5421579659f1f622cadd3c501a8a4d0081d0d9393e83c67 SHA512 dc7189756bf607cf047e277d8b658ed90d64cbec1cb284e1c91aea42891cfbb3a1a7b8be589419caf6b8c4ed7b56b87d6e083f1e0c2309d23c24e64928f1e0cc WHIRLPOOL ccb39b4af15e555584aae2c21d428ac051985df112cfd3761679bc9a4343202ef713417927508b22bb420bc6cf7193a25b6467b38e0141283caf6d0497837576
diff --git a/app-misc/pport/pport-0.6.9.ebuild b/app-misc/pport/pport-0.6.9.ebuild
new file mode 100644
index 0000000..6ee966b
--- /dev/null
+++ b/app-misc/pport/pport-0.6.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A simple yet handy program for accessing the output pins of the parallel port."
+#HOMEPAGE="${PN}.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+DEPEND="sys-libs/glibc
+ ssl? ( dev-libs/openssl )"
+IUSE="ssl"
+
+src_compile() {
+ local myconf
+ use ssl && myconf='--enable-ssl=yes'
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dobin src/pport src/pportd
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS THANKS doc/*
+ doman man/pport.1 man/pportd.1
+}