summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/reprepro/reprepro-4.16.0.ebuild')
-rw-r--r--app-admin/reprepro/reprepro-4.16.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/reprepro/reprepro-4.16.0.ebuild b/app-admin/reprepro/reprepro-4.16.0.ebuild
new file mode 100644
index 0000000..cac54a2
--- /dev/null
+++ b/app-admin/reprepro/reprepro-4.16.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Copyright 2015-2015 Quentin Heath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit flag-o-matic
+
+DESCRIPTION="Debian APT repository creator and maintainer application"
+HOMEPAGE="http://packages.debian.org/reprepro"
+SRC_URI="https://alioth.debian.org/frs/download.php/file/4109/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="archive bzip2 gpgme"
+
+DEPEND=">=sys-libs/db-4.3
+ sys-libs/zlib
+ gpgme? ( app-crypt/gpgme dev-libs/libgpg-error )
+ archive? ( app-arch/libarchive )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ use gpgme && append-cppflags -I/usr/include/gpgme
+ econf \
+ $(use_with gpgme libgpgme) \
+ $(use_with archive libarchive) \
+ $(use_with bzip2 libbz2)
+}